none
Biztalk 2013 Recieve Location with new WCF-SAP adapter disables when connector type changes to Nco(Sap .net connector 3.0) RRS feed

  • Question

  • I am using the new WCF-SAP adapter with BizTalk 2013.This adapter gives the option to use the classic RFCSdk or the SAP .net connector. My SAP Receive location works fine with the classic RFCSdk connector type but when I change it to NCo my receive location doesn't enable. I receive the following error in the Application log when I try to enable it after restarting the Host instance

    I got the .net connector option after installin cu2 package for Biztalk Adapters. I am successfully able to consume adapter services in VS2012 using NCo and RFCSdk set as the connector type binding properties but the recieve location in Biztalk Administrator console does,nt work with the bindings that were generated in VS2012.

    The Messaging Engine failed to add a receive location "WcfReceiveLocation_SAPBinding_IdocDEBMAS05V3R740_Custom" with URL "**sap://CLIENT=300;LANG=EN;@a/sv-sapecc-dv2/00?GWHOST=sv-sapecc-dv2&GWSERV=sapgw00&ListenerDest=BIZTALKDEV&ListenerGwServ=sapgw00&ListenerGwHost=sv-sapecc-dv2&ListenerProgramId=BIZTALKDEV&RfcSdkTrace=True&AbapDebug=False**" to the adapter "WCF-Custom". Reason: "System.IndexOutOfRangeException: Index was outside the bounds of the array.
       at Microsoft.Adapters.SAP.NCo.RfcServerConnection.GetParameters(String serverName)
       at SAP.Middleware.Connector.RfcServerManager.GetServer(String serverName, Type[] rfcFunctionHandlers, RfcRepository repository)
       at Microsoft.Adapters.SAP.NCo.RfcServerConnection.Open(RfcClientConnection conn)
       at Microsoft.Adapters.SAP.SAPInboundContract.InitializeRfcServerConnectionNCo(String connectionArguments)
       at Microsoft.Adapters.SAP.SAPInboundContract.StartListener(String[] listenerActions, TimeSpan timeout)
       at Microsoft.ServiceModel.Channels.Common.Channels.AdapterChannelListener`1.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.Dispatcher.ChannelDispatcher.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at Microsoft.BizTalk.Adapter.Wcf.Runtime.WcfReceiveEndpoint.Enable()
       at Microsoft.BizTalk.Adapter.Wcf.Runtime.WcfReceiveEndpoint..ctor(BizTalkEndpointContext endpointContext, IBTTransportProxy transportProxy, ControlledTermination control)
       at Microsoft.BizTalk.Adapter.Wcf.Runtime.WcfReceiver`2.AddReceiveEndpoint(String url, IPropertyBag adapterConfig, IPropertyBag bizTalkConfig)".


    On the second Try I get the following Error

     The Messaging Engine failed to add a receive location "WcfReceiveLocation_SAPBinding_IdocDEBMAS05V3R740_Custom" with URL "sap://CLIENT=300;LANG=EN;@a/sv-sapecc-dv2/00?GWHOST=sv-sapecc-dv2&GWSERV=sapgw00&ListenerDest=BIZTALKDEV&ListenerGwServ=sapgw00&ListenerGwHost=sv-sapecc-dv2&ListenerProgramId=BIZTALKDEV&RfcSdkTrace=True&AbapDebug=True" to the adapter "WCF-Custom". Reason: "SAP.Middleware.Connector.RfcInvalidStateException: destination configuration already initialized
       at SAP.Middleware.Connector.RfcDestinationManager.RegisterDestinationConfiguration(IDestinationConfiguration config)
       at Microsoft.Adapters.SAP.NCo.RfcServerConnection.Open(RfcClientConnection conn)
       at Microsoft.Adapters.SAP.SAPInboundContract.InitializeRfcServerConnectionNCo(String connectionArguments)
       at Microsoft.Adapters.SAP.SAPInboundContract.StartListener(String[] listenerActions, TimeSpan timeout)
       at Microsoft.ServiceModel.Channels.Common.Channels.AdapterChannelListener`1.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.Dispatcher.ChannelDispatcher.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)
       at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
       at Microsoft.BizTalk.Adapter.Wcf.Runtime.WcfReceiveEndpoint.Enable()
       at Microsoft.BizTalk.Adapter.Wcf.Runtime.WcfReceiveEndpoint..ctor(BizTalkEndpointContext endpointContext, IBTTransportProxy transportProxy, ControlledTermination control)
       at Microsoft.BizTalk.Adapter.Wcf.Runtime.WcfReceiver`2.AddReceiveEndpoint(String url, IPropertyBag adapterConfig, IPropertyBag bizTalkConfig)".

    Any help is highly appreciated.

    Regards,

    Amjad Iqbal

    Wednesday, February 10, 2016 1:23 AM

Answers

  • Hi Amjad,

    In the receive URL, I see you have specified ListenerGwServ, ListenerGwHost, and ListenerProgramId parameters along with ListenerDest parameter.

    If you have no dependency on saprfc.ini file, Can you remove the ListenerDest and RfcSdkTrace parameters from the URL and check if it's working?

    Thanks

    Pavan
    • Marked as answer by Amjad347 Thursday, February 11, 2016 9:55 AM
    Thursday, February 11, 2016 8:58 AM

All replies

  • Hi Amjad ,

    This has been reported couple of times  after CU update for BizTalk 2013.

    Unfortunately there has been no update as of now . Will update thread once hear something about this.

    Thanks

    Abhishek

     


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply

    Wednesday, February 10, 2016 2:35 AM
  • Hi Amjad,

    In the receive URL, I see you have specified ListenerGwServ, ListenerGwHost, and ListenerProgramId parameters along with ListenerDest parameter.

    If you have no dependency on saprfc.ini file, Can you remove the ListenerDest and RfcSdkTrace parameters from the URL and check if it's working?

    Thanks

    Pavan
    • Marked as answer by Amjad347 Thursday, February 11, 2016 9:55 AM
    Thursday, February 11, 2016 8:58 AM
  • Thank you so much .Worked Like a charm Pavan. I am new to SAP can you explain why this is working.

    Regards,

    Amjad Iqbal

    Thursday, February 11, 2016 9:46 AM
  • Hi Amjad,

    What change you have done to enable the Receive location after change the connector type as "Nco"?

    Monday, September 12, 2016 12:04 PM