none
Converting rdlc files from 2005 to 2008 version RRS feed

  • Question

  • Hello,

    I know there are several posts dedicated to this issue, but none of them really solved my problem. Here is my scenario:

    I have a Windows Forms application that was build using vs2005. This application has several local reports in it.

    I recently decided to upgrade it to vs2010. The project conversion went well and everything is building and executing fine. However, when I started adding my reports, I started having problems. I should probably tell you that I have the Report Viewer 2010 installed and all my references are pointing to the correct version of Microsoft.ReportingServices.Common and Microsoft.ReportingServices.WinForms. In my toolbox I have the 10.0 version of the ReportViewer control.

    I also went to: C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v10.0\ReportingServices and changed Microsoft.ReportingServices.targets from <UsingTask TaskName="Microsoft.Reporting.RdlCompile" AssemblyName="Microsoft.ReportViewer.Common, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/> to <UsingTask TaskName="Microsoft.Reporting.RdlCompile" AssemblyName="Microsoft.ReportViewer.Common, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>. For some reason, the version pointed to 9.0 instead of 10.0.

    So, I added my first report. Immediately I received the "Error    44    The "Microsoft.Reporting.RdlCompile" task could not be loaded from the assembly Microsoft.ReportViewer.Common, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a.  Confirm that the <UsingTask> declaration is correct, that the assembly and all its dependencies are available, and that the task contains a public class that implements Microsoft.Build.Framework.ITask.".

    When I try top open it, I was asked if I want to convert it. I said "Yes". The report converted, but it was absolutely blank. In addition to this, I got the following error:

    Error    44    The "RdlCompile" task was not found. Check the following: 1.) The name of the task in the project file is the same as the name of the task class. 2.) The task class is "public" and implements the Microsoft.Build.Framework.ITask interface. 3.) The task is correctly declared with <UsingTask> in the project file, or in the *.tasks files located in the "C:\windows\Microsoft.NET\Framework\v4.0.30319" directory.

    If I exclude the old reports from the project, the solution builds fine. If I add a new report, I get the The "Microsoft.Reporting.RdlCompile" task could not be loaded... error. I even tried changing the UsingTask line in Microsoft.ReportingServices.targets to   <UsingTask  TaskName="Microsoft.Reporting.RdlCompile" AssemblyName="Microsoft.ReportViewer.WinForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>. I saw a suggestion to change Common with WinForms.

    Has anyone ever solved this issue?

    Thank you for your help.

    Sunday, April 29, 2012 12:17 AM