locked
"Unable to configure this computer to allow remote debugging" when trying to remote debug on Surface RRS feed

  • Question

  • I'm trying to remote debug my application on a Surface device and am having trouble. It used to work, but for some reason it's not working anymore.

    To repro:

    1. Launch the remote debugger on the Surface
    2. In the remote debugging configuration dialog check all the networks and then tap Configure remote debugging
    3. Tap yes in the UAC dialog 

    Result: Unable to configure this computer to allow remote debugging. The parameter is incorrect.

    Expected result: Remote debugging starts.

    This used to work so I'm not sure why it won't start up anymore. I've tried uninstalling and reinstalling, and also tried rebooting the Surface. No luck.

    Anyone know how to get this to work?

    Neil

    Saturday, November 17, 2012 10:13 PM

Answers

  • Here is the work around spelled out a little more explicitly in case anyone else runs into this:

    1. If running, close the remote debugger

    2. Run 'wf.msc' from the Windows start page, or from Winkey + R

    2. The Windows Firewall admin tool should start. Switch to 'Inbound Rules'.

    3. Find the rules with name 'Visual Studio Remote Debugging Monitor'

    4. Delete these rules

    5. Restart the remote debugger

    We are looking at fixing this in a future release, but for now, please use the work around.

    Gregg Miskelly


    Visual Studio Debugger Dev

    Thursday, December 20, 2012 11:52 PM
  • This isn't a problem on the machine with VS. It's a problem on the Surface. The remote debugger won't start up, so trying a different machine to connect to it is pointless. The remote debugger won't run on the Surface.

    None of the computers involved are on a domain.

    I'll open a connect bug.

    Neil

    Thursday, November 22, 2012 8:22 PM
  • Hi Neil,

    I will vote it :)

    http://connect.microsoft.com/VisualStudio/feedback/details/771990/unable-to-start-remote-debugging-on-a-surface#details

    Have a nice weekend,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Friday, November 23, 2012 2:13 AM

All replies

  • Hi Neil,

    Thank you for posting in the MSDN forum.

    Just to make this issue clearly, do you mean that it worked well before? If so, do you change anything? Could you share us the detailed error message if you got?

    If possible, I suggest you check the settings when you configure the remote debugger. See “Remote Debugging your Windows Store app on your Surface” and “Remote Debugging to your Surface Machine”.

    Have a nice day,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, November 21, 2012 6:47 AM
  • Jack,

    Yes, this used to work just fine. No, I didn't change anything that I'm aware of. The complete error message is what I put in the results section of my report:

    Unable to configure this computer to allow remote debugging. The parameter is incorrect.

    I've already tried all the steps in Tim's blog entry, that's how I got remote debugging to work in the first place. It just isn't working anymore due to the error I mention above.

    Neil

    Wednesday, November 21, 2012 2:34 PM
  • Hi Neil,

    Sorry for my reply no help.

    Unable to configure this computer to allow remote debugging. The parameter is incorrect.

    If you have other machine, you could try to connect to the remote machine with it. I didn’t meet this error before, if possible, I suggest you reopen your machine and reopen your VS, check it, please open your VS as the admin.

    In addition, we would make sure that we have the full permissions and other requirements like this document when we debug the specific app remotely. You could try to check the Event log, and maybe you could find more useful information.

    If still no help, like this thread “Configuring VS2012 to Remotely Debug Surface Application (Domain vs Workgroup)”, to help you resolve this issue, would you please create connect report for it? You will get email notification for update.http://connect.microsoft.com/VisualStudio/feedback/CreateFeedback.aspx

    Sincerely,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, November 22, 2012 8:55 AM
  • This isn't a problem on the machine with VS. It's a problem on the Surface. The remote debugger won't start up, so trying a different machine to connect to it is pointless. The remote debugger won't run on the Surface.

    None of the computers involved are on a domain.

    I'll open a connect bug.

    Neil

    Thursday, November 22, 2012 8:22 PM
  • Hi Neil,

    I will vote it :)

    http://connect.microsoft.com/VisualStudio/feedback/details/771990/unable-to-start-remote-debugging-on-a-surface#details

    Have a nice weekend,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Friday, November 23, 2012 2:13 AM
  • same problem here!!!

    it was working for several days and just 1hr ago, and I did not change anything.

    Wednesday, November 28, 2012 2:40 AM
  • I experienced the same problem. I tried to run the remote tools configuration wizard, but got a similar error to above. I then re-installed and got the same error as above.

    I have managed to resolve the problem however, by going into windows firewall and deleting all of the inbound rules for "Visual Studio Remote Debugging Monitor". After doing that I was then able to successfully complete the configuration and remote debugging is working nicely again.

    Incidentally, I have two wireless networks and the problem appeared to occur after my Surface decided to connect to the second network. 

    • Proposed as answer by Neil Enns Thursday, December 6, 2012 5:49 PM
    Thursday, December 6, 2012 5:47 PM
  • Thanks for the suggestion S1mm0t! I'll give this a try tonight, I'm hopeful it will resolve the issue.

    Neil

    Thursday, December 6, 2012 5:49 PM
  • I can confirm this fixed the problem. Run mmc.exe, load up the add-in for windows firewall, and delete the existing inbound rules for Visual Studio Remote Debugging Monitor. Then run the remote debugger and it works again.

    YAY!

    Neil

    Saturday, December 8, 2012 3:05 AM
  • Here is the work around spelled out a little more explicitly in case anyone else runs into this:

    1. If running, close the remote debugger

    2. Run 'wf.msc' from the Windows start page, or from Winkey + R

    2. The Windows Firewall admin tool should start. Switch to 'Inbound Rules'.

    3. Find the rules with name 'Visual Studio Remote Debugging Monitor'

    4. Delete these rules

    5. Restart the remote debugger

    We are looking at fixing this in a future release, but for now, please use the work around.

    Gregg Miskelly


    Visual Studio Debugger Dev

    Thursday, December 20, 2012 11:52 PM
  • I am going through the same pain.

    1. I have attempted the suggested delete inbound firewall params work-around.

    2. I provided my dev machine's username and password to the remote debugger configuration wizard on the Surface device.

    3. I rebooted both machines.

    I am not sure what else I need to do to test this on my Surface device.

    Are there any other steps that I'm missing?

    Friday, December 21, 2012 12:05 PM
  • ... and me.

    I've looked at all the documentation referred to here and the problem persists. This issue is taking more of my time than the actual development of my App.

    I did find one person who had this problem but by taking his Surface to another network found that everything worked OK, leaving him to think the problem lay with his home router. This may be the case with me, but does anyone know what I can check for.

    This is wearing me out!

    Wednesday, March 13, 2013 10:46 AM
  • Worked like a charm for me, thanks!

    The problem also happened after my Surface got connected to a second WiFi network.

    Saturday, March 30, 2013 8:35 PM