none
HAT starts very slowly RRS feed

  • Question

  •  

    Hi all,

     

    i have a  problem with the btshatapp starting very slowly. I have several BizTalk Servers in a farm. On machine 1, the HAT starts after a few seconds, on machine 2 (same farm) it takes more than 30 seconds. As soon as it starts it works fine, i don´t get any timeouts when executing queries. Does anybody have an idea as to why this could happen?

     

    regards

    derk

    Wednesday, June 4, 2008 11:36 AM

All replies

  • So on machine 1, is this the server that was the first machine added to your BizTalk group? When HAT launches, it looks up the information for the BizTalk management database and for a machine that is not the primary (first) server in the BizTalk group, HAT may be required to look up related information on the primary (first) server in order to structure the HAT queries appropriately.

     

    Also, this delay might actually be related to the topology of your SQL Server machines. Could you give more information about how SQL Server is organized in your environment? Also, are all of the BizTalk databases located on a single server? What you experiencing could be caused by the load on your SQL Servers so a recommended practice is to spread BizTalk databases across different filegroups or SQL Server instances for better performance. Here are a few links on database optimization techniques (like the filegroup one) for BizTalk: http://technet.microsoft.com/en-us/library/bb743398.aspx, and http://technet.microsoft.com/en-us/library/cc594529.aspx.

     

    Thanks,

     

     

     

    Thursday, June 5, 2008 12:19 PM
    Moderator