none
Getting error 400 when trying to publish from bingmapsportal.com RRS feed

  • Question

  • Hi, I just created a data source, with only 1 record, in order to start testing my application.

    The data source is uploaded and geocoded, according to the "Manage My Data Sources" tab. But when pressing the publish button, it gives me the following error:

    BingTest has error : The remote server returned an error: (400) Bad Request.

    I´m out of ideas, as I´m trying to publish from inside www.bingmapsportal.com, and not my own application.

    Thanks

    Wednesday, February 5, 2014 1:54 PM

Answers

  • When I try and run your data source I get and error indicating that more than one column has the same name. Looking at the data source I don't se this but suspect the issue could be that you are not using the proper column names for addresses:

    AddressLine(Edm.String)
    Locality(Edm.String)
    AdminDistrict(Edm.String)
    PostalCode(Edm.String)
    CountryRegion(Edm.String)

    In your data source you have addressline which I suspect is causing an issue with the expected coloumn name. Changing the data source to the following worked for me:

    Bing Spatial Data Services, 1.0, Locations
    id(Edm.String,primaryKey),locationtype(Edm.String),dba(Edm.String),AddressLine(Edm.String),Locality(Edm.String),AdminDistrcit(Edm.String),PostalCode(Edm.String),phone(Edm.String),url(Edm.String),urltype(Edm.String),Latitude(Edm.Double),Longitude(Edm.Double),p(Edm.String),o(Edm.String),g(Edm.String),c(Edm.String),a(Edm.String),gr(Edm.String),f(Edm.String)
    13245,R,abc,1610 Some Street,PULASKI,TN,38478-0000,,www.url.com,,35.2046198,-87.0620945,,abc-1234,abc-1234,abc-1234,abc-1234,abc-1234,abc-1234


    http://rbrundritt.wordpress.com

    • Proposed as answer by Ricky_Brundritt Wednesday, February 5, 2014 3:35 PM
    • Marked as answer by Avan_Arg Wednesday, February 5, 2014 4:36 PM
    Wednesday, February 5, 2014 3:35 PM

All replies

  • Can you provide the sample data source you are uploading?

    http://rbrundritt.wordpress.com

    Wednesday, February 5, 2014 2:05 PM
  • This is the data I uploaded, as a CSV file:

    Bing Spatial Data Services, 1.0, Locations
    id(Edm.String,primaryKey),locationtype(Edm.String),dba(Edm.String),addressline(Edm.String),city(Edm.String),state(Edm.String),zip(Edm.String),phone(Edm.String),url(Edm.String),urltype(Edm.String),Latitude(Edm.Double),Longitude(Edm.Double),p(Edm.String),o(Edm.String),g(Edm.String),c(Edm.String),a(Edm.String),gr(Edm.String),f(Edm.String)
    13245,R,abc,1610 Some Street ,PULASKI,TN,38478-0000,,www.url.com,,35.2046198,-87.0620945,,abc-1234,abc-1234,abc-1234,abc-1234,abc-1234,abc-1234

    According to the data source list, the data has been geocoded without a problem:

    BingTest                            2/5/2014 1:36:14 PM                                      5/6/2014 6:29:00 AM                Geocoded

    Any help would be greatly appreciated

    Wednesday, February 5, 2014 2:16 PM
  • When I try and run your data source I get and error indicating that more than one column has the same name. Looking at the data source I don't se this but suspect the issue could be that you are not using the proper column names for addresses:

    AddressLine(Edm.String)
    Locality(Edm.String)
    AdminDistrict(Edm.String)
    PostalCode(Edm.String)
    CountryRegion(Edm.String)

    In your data source you have addressline which I suspect is causing an issue with the expected coloumn name. Changing the data source to the following worked for me:

    Bing Spatial Data Services, 1.0, Locations
    id(Edm.String,primaryKey),locationtype(Edm.String),dba(Edm.String),AddressLine(Edm.String),Locality(Edm.String),AdminDistrcit(Edm.String),PostalCode(Edm.String),phone(Edm.String),url(Edm.String),urltype(Edm.String),Latitude(Edm.Double),Longitude(Edm.Double),p(Edm.String),o(Edm.String),g(Edm.String),c(Edm.String),a(Edm.String),gr(Edm.String),f(Edm.String)
    13245,R,abc,1610 Some Street,PULASKI,TN,38478-0000,,www.url.com,,35.2046198,-87.0620945,,abc-1234,abc-1234,abc-1234,abc-1234,abc-1234,abc-1234


    http://rbrundritt.wordpress.com

    • Proposed as answer by Ricky_Brundritt Wednesday, February 5, 2014 3:35 PM
    • Marked as answer by Avan_Arg Wednesday, February 5, 2014 4:36 PM
    Wednesday, February 5, 2014 3:35 PM
  • Yes! That worked.

    Not sure why it allowed me to upload the csv, even though the address field names were wrong.

    And the 400 error is not a lot of information neither.

    But yeah, using your headers I was able to upload, publish in seconds.

    Thanks! Marking as answer

    Wednesday, February 5, 2014 4:36 PM