locked
AccessDeniedExeption SSRS 2008 R2 RRS feed

  • Question

  • User-1121540557 posted
    Hi All,
    I am having this crazy problem with reporting service(and there is no information on the net)
    Microsoft.ReportingServices.Diagnostics.Utilities.AccessDeniedException: The permissions granted to user 'IIS APPPOOL\ASP.NET v4.0 Classic' are insufficient for performing this operation.
    I am using a asp.net 4.0 webapplication (i`ve migrated it from vs2008) where it is working perfect(on sql server 2008 standard)
    It looks like ReportingService2005.wsdl doesn`t take over the credentials i`m passing true via
    public class CustomReportCredentials : Microsoft.Reporting.WebForms.IReportServerCredentials
    I`ve already added the user 'IIS APPPOOL\ASP.NET v4.0 Classic' via the home page on the reportmanager...it didn`t do anything...does any one knows how to work arround this ridiculous problem?
    I realy hope any one can help me to solve this f..issue(it is already costing me two days..)
    Best regards,
    Mark
    Monday, May 2, 2011 2:21 PM

Answers

  • User311508580 posted

    Please grant the permission to your user.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, May 3, 2011 11:51 PM

All replies

  • User311508580 posted

    Please grant the permission to your user.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, May 3, 2011 11:51 PM
  • User-1121540557 posted

    Hi,

    I`ve already granted permissions to the user(wrote that in my previous post)

    The user where i loggin with, is a member of the Administrators(this group is already authorized to all the folders on the report server/manager)

    So if you have any other suggestions?

    best regards,

    Mark

    Wednesday, May 4, 2011 2:41 AM
  • User-1121540557 posted

    Issue is Solved!

    first i added the user in the Root security(Home) and i didn`t add the user to report folder security(because i tought that when you give the user enough rights, these rights where sufficient for all sub folders...BIG MISTAKE THEY ARE NOT!! Cool)

    So i added the user to the static report folder, and al worked fine..

    Thanks for your anwser and solution!

    Best regards,

    Mark

    Wednesday, May 4, 2011 6:13 AM
  • User1471008070 posted

    Thank you for sharing your solutions and experience here. It will be very beneficial for other community members who have similar questions.

    Sunday, May 8, 2011 11:15 PM