none
Required kinect software not detected error RRS feed

  • Question

  • I'm trying to get the kinect v2 sensor working on an i7 workstation running windows 8.1.

    It complained about the USB3 interface (intel i7/c216 family chipset) so I purchased the SIIG 2 port USB 3.0 PCIe card that was "known compatible" on the hardware requirement list. I'm getting the same behavior on it - the verification tools says USB3 port detected, unknown bandwidth, Kinect Detected OK, Verify Kinect software installed FAILS and Verify Kinect Depth and color FAILS.

    I've re-installed the 2.0 SDK. (The workstation does have the previous 1.0 SDK installed for use with the 360 sensor - which worked perfectly.)  (The sensor does work on my HP notebook running windows 10, so it and the windows interface/power adapter appear to be OK)

    Any ideas on where to go from here? Thanks!!

    Monday, August 28, 2017 11:16 PM

Answers

  • FIXED! (I'm posting this to hopefully help anyone else facing this issue).

    I did some more digging in this forum and found a reference to the "Kinect Monitor" service.
    I checked in services.msc and sure enough it was not running. I reset the service to auto-start and manually started it - which did not fix the issue when using the SIIG PCIe USB3 card.

    The Kinect V2 Configuration Verifier tool gained one more step - clearing the "Verify Kinect Software Installed", however the frame rate was flaky - 1 to 2 frames per second - so the final verification step failed. Getting closer but not there yet...

    However, when I plugged the Kinect back into the USB3 port on the motherboard everything worked (Intel i7/c216 USB chipset).

    So before spending money on a new USB card, check that the Kinect Monitor service is running.
    On my setup, the keyboard and mouse are on the motherboard's USB2 buss, the Kinect is the only device on the USB3 buss, which seems to be working fine.

    • Marked as answer by w2g Tuesday, August 29, 2017 12:08 AM
    Tuesday, August 29, 2017 12:08 AM