locked
Error when submitting experiment: "413 Request Entity Too Large" RRS feed

  • Question

  • Hello, 

    I have the following issue:

    SnapshotException: {
        "error_details": "<html>\r\n<head><title>413 Request Entity Too Large</title></head>\r\n<body>\r\n<center><h1>413 Request Entity Too Large</h1></center>\r\n<hr><center>nginx</center>\r\n</body>\r\n</html>\r\n",
        "status_code": 413,

    It comes when running:

    run = exp.submit(config=hdc)
    Thank you

    Tuesday, January 21, 2020 2:39 PM

Answers

  • I have resolved the issue by deleting a large model file (~400mb) which was in my snapshot upload folder. After that, I was able to submit the experiment.
    • Marked as answer by aiwalter Thursday, January 23, 2020 12:24 PM
    Thursday, January 23, 2020 12:24 PM

All replies

  • Hi,

    This could be due to the storage limits of experiment snapshots (limit is 300MB or 2000 files). Can you try storing your experiment files on a datastore or follow any of the other options provided here? Thanks.

      

    Regards,

    GiftA-MSFT.

    If a post helps to resolve your issue, please click “Mark as Answer” and/or “Vote as helpful”. By marking a post as Answered and/or Helpful, you help others find the answer faster.  Thanks.

    Tuesday, January 21, 2020 10:55 PM
  • Hi, 

    Yes, the error.. 

    While attempting to take snapshot of .
    Your total snapshot size exceeds the limit of 300.0 MB

    came also before, and I resolved it by increasing the limit with... 

    azureml._restclient.snapshots_client.SNAPSHOT_MAX_SIZE_BYTES = 'insert_desired_size'
    So the described error above seems to be a different issue, which I can not resolve with your provided information.

    Wednesday, January 22, 2020 8:31 AM
  • No, I got a new error:

    SnapshotException: {
        "error_details": {
            "correlation": {
                "operation": "xxxxxxxxxxxxxxx",
                "request": "xxxxxxxxxxxxx"
            },
            "environment": "westeurope",
            "error": {
                "code": "ServiceError",
                "message": "InternalServerError"
            },
            "location": "westeurope",
            "time": "2020-01-22T09:31:15.9079452+00:00"
        },
        "status_code": 500,

    Wednesday, January 22, 2020 9:33 AM
  • Hi,

    From the information I gathered, the new error is still related to old error. The limit is only used for client-side validation (so that the attempt fails even before reaching the service). By increasing this limit, you are able to bypass this validation and force the Python SDK to send a request to take the snapshot. However, the service still rejects it because it doesn't accept that large of data. I suggest you follow other options provided here. Hope this helps. Thanks.

    Regards,

    GiftA-MSFT.

    If a post helps to resolve your issue, please click “Mark as Answer” and/or “Vote as helpful”. By marking a post as Answered and/or Helpful, you help others find the answer faster.  Thanks.

    Wednesday, January 22, 2020 4:22 PM
  • Hi, 

    could you please investigate the InternalServerError? It is very encrypted and I am not sure if it is related to configurations which I am able to access.

    Thx.

    Thursday, January 23, 2020 9:46 AM
  • I have resolved the issue by deleting a large model file (~400mb) which was in my snapshot upload folder. After that, I was able to submit the experiment.
    • Marked as answer by aiwalter Thursday, January 23, 2020 12:24 PM
    Thursday, January 23, 2020 12:24 PM
  • Hi,

    Awesome, glad it worked out, thanks for the update.

    Regards,

    GiftA-MSFT.

    If a post helps to resolve your issue, please click “Mark as Answer” and/or “Vote as helpful”. By marking a post as Answered and/or Helpful, you help others find the answer faster.  Thanks.

    Thursday, January 23, 2020 6:41 PM