locked
IIS7, Vista, ASP, Error 500.0 and many grey hairs RRS feed

  • Question

  • User-1395785364 posted

    Hello all,

    I am having the time of my life with IIS7 - really. (There are no smileys showing sarcasm so I hope you can see through it!)

    I have a laptop with Vista Business, and I've enabled every last feature in IIS7 (since there's so much more to it than IIS6, I wanted to start off without missing anything). I have some old sites that worked well in IIS6 (including my old campaign website) which were all ASP with an MS Access database.

    I tried to test this site, and a much simpler site (that's only named .asp, but has no VB within it whatsoever), and I'm getting an error when I try to serve either using IIS7 from http://localhost:

    Error: 500.0 (Internal Server Error)
    Error Code: 0x80070005

    Event Viewer specifies this simple log:
    Could not load all ISAPI filters for site 'sitename'.  Therefore site startup aborted.

    It also gives this detailed information:

    - Provider
    [ Name] Microsoft-Windows-IIS-W3SVC-WP
    [ Guid] {670080D9-742A-4187-8D16-41143D1290BD}
    [ EventSourceName] W3SVC-WP
    - EventID 2268
    [ Qualifiers] 49152
    Version 0
    Level 2
    Task 0
    Opcode 0
    Keywords 0x80000000000000
    - TimeCreated
    [ SystemTime] 2007-01-20T00:22:24.000Z
    EventRecordID 3228
    Correlation
    - Execution
    [ ProcessID] 0
    [ ThreadID] 0
    Channel Application
    Computer computername
    Security
    - EventData

    SiteName sitename

     

    Has anyone encountered a similar error? I know there are several steps to enable ASP in IIS, but what seems like something that should be simple, is instead fast becoming a growing pain.

    Any help is much appreciated.

     

    Thanks all,

    Donald

    (I've also attached the full HTTP error below displayed in the browser)

    ===============================

    Server Error


    HTTP Error 500.0 - Internal Server Error

    Description: The page cannot be displayed because an internal server error has occurred.

    Error Code: 0x80070005

    Notification: BeginRequest

    Module: IIS Web Core

    Requested URL: http://localhost:80/

    Physical Path: <path which does include spaces>

    Logon User: Not yet determined

    Logon Method: Not yet determined

    Handler: Not yet determined

    Most likely causes:

    • IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred.
    • IIS was not able to access the web.config file for the Web site or application. This can occur if the NTFS permissions are set incorrectly.
    • IIS was not able to process configuration for the Web site or application.
    • The authenticated user does not have permission to use this DLL.
    • The request is mapped to a managed handler but the .NET Extensibility Feature is not installed.

    What you can try:

    • Ensure that the NTFS permissions for the web.config file are correct and allow access to the Web server's machine account.
    • Check the event logs to see if any additional information was logged.
    • Verify the permissions for the DLL.
    • Install the .NET Extensibility feature if the request is mapped to a managed handler.
    • Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here.

    More Information... This error means that there was a problem while processing the request. The request was received by the Web server, but during processing a fatal error occurred, causing the 500 error.

    Microsoft Knowledge Base Articles:

    • 294807

    Server Version Information: Internet Information Services 7.0.

    Friday, January 19, 2007 7:47 PM

All replies

  • User989702501 posted
    Mm.. I would first try filemon to trace for any access related issue, then try the failed request tracing as stated in the error msgs.
    Thursday, January 25, 2007 12:44 AM
  • User-2026410440 posted

    I would search \windows\system32\inetsrv\config for any <isapiFilters> section.  Are there ISAPI filters registered in configuration that aren't on the system?  That would cause the error...

     

    Thursday, January 25, 2007 2:38 PM
  • User-1395785364 posted
    I tried Failed Request Tracing but it wouldn't even generate a log file. Filemon (Process Monitor in Vista) is too quick to even let me see anything that could be the cause of the problem.
    Sunday, January 28, 2007 1:56 AM
  • User-1395785364 posted

    Hi there Bill,

    I checked - all ISAPI filters registered do appear in the applicationHost.config file as I expect it to appear.

    Still lost :'(

     

    Thanks!

    D

    Sunday, January 28, 2007 2:01 AM
  • User989702501 posted
    Mmm.... too fast? You can run it, browse the page, then stop the filemon, and then check the log.

    Does the log say which ISAPI filters ?
    Sunday, January 28, 2007 9:55 PM
  • User1073881637 posted

    Filemon for Vista has been updated to process monitor

    http://www.microsoft.com/technet/sysinternals/ProcessesAndThreads/Filemon.mspx

    1) check to make sure the Handler mapping for asp is enabled
    2) browse the ASP feature to see if anything stands out.
    3) Does aspx and htm pages work?

    Sunday, January 28, 2007 10:51 PM
  • User-1395785364 posted

    Hey,

    I checked for the first two things and nothing unusual. I don't host aspx files but when I built a test asp file, it failed once, but another test ASP file worked (and there was nothing unusual about the two files).

    I thought it may have also been a permissioning problem to the access DB but it doesn't appear to be the case. What's the coles notes on the IIS_WPG group, by the way?

    Anyway, I'm growing increasingly impatient and I think I'm going to use IIS5 on my Win2K Server to serve pages, and I'll find a way to cache that on my laptop so I can work on my sites remotely without needing to access the server. IIS7 is way too much a hassle.

    Monday, February 5, 2007 12:47 AM
  • User757815045 posted

    I had the same problem.  All I did was change the folder permissions and it all work ok for me.

    Network Services and Everyone should have Read + Execute.

    Administrators and system should have FULL.

    Good luck!

    Mark

    Wednesday, February 14, 2007 11:16 AM