none
BizTalk 2016 CU6 Feature Pack 3 SFTP Adapter Issues RRS feed

  • Question

  • Environment: BizTalk 2016 CU6 Feature Pack 3 

    Copied WinScp.exe  and WinScpnet.dll   version 5.13.1.0 to C:\Program Files (x86)\Microsoft BizTalk Server 2016

    I have a receive location using SFTP Adapter to download files. The files are downloaded but not deleted from sftp server. Because of this the Receive location is continuously re downloading the file. I have Retain After Download to false. I am not sure what other properties I need to set for the Receive Location to

    1. Download files from sftp server 

    2. Delete the files from sftp server after download



    • Edited by Haritha K Friday, July 19, 2019 7:41 PM
    Friday, July 19, 2019 6:54 PM

All replies

  • Are you seeing any warnings or errors saying that it couldn't delete the files?   If there is maybe the user does not have enough rights to delete the files.
    Wednesday, July 24, 2019 9:13 PM
  • There are not errors that the file couldn't be delete. When I opened it in FileZilla I see the permissions for the file on the sftp server was 

    -rwxrwxrwx

    Monday, July 29, 2019 5:01 PM
  • And what does it say in the sftp.txt log file?

    Have you tried changing your Polling Interval?   The default every 5 seconds is a bit much.

    Tuesday, July 30, 2019 8:29 PM
  • This definitely is not a permission issue. When I was enabling and disabling the receive location it worked for couple of files but not all of them. It was able to download all the files but delete only few files.

    I did try changing the polling and no luck. 

    I tried with another sftp server. It worked fine. It was able to download and delete all the files.





    • Edited by Haritha K Tuesday, July 30, 2019 8:37 PM
    Tuesday, July 30, 2019 8:36 PM
  • Did you find solution for this ?  I am running into same problem. 
    Monday, August 5, 2019 1:24 AM
  • Did you see this thread BizTalk 2016 SFTP is not working for me where it looks like it possibly was an issue caused by doing a in-place upgrade from BizTalk 2013 R2 to BizTalk 2016.

    In the environments where this is not working, were they clean installs of BizTalk 2016 or in-place upgrades?

    Monday, August 5, 2019 1:30 AM
  • I did a fresh install. Only thing I did was got bindings from old(2013 R2) system to new system (2016)
    Monday, August 5, 2019 1:50 AM