VS 2015 Unusably Slow after Windows 10 Anniversary Update


  • Has anyone noticed extreme lag in VS 2015 after installing the Windows 10 Anniversary Update? Opening solutions takes several minutes and once open, a document will take minutes to scroll.
    Sunday, August 28, 2016 4:55 PM


  • Hi Shawn Olson,

    I have installed the Windows 10 Anniversary Update in my surface and VS could run in normal. Please refer to the following steps to troubleshot your issue:

    1). Please update your VS to the latest version (Version 14.0.25425.01), which has fox some bugs in previous versions.

    2). Please check your task manager to observer whether the occupy rates of CPU, Memory and Disk are in normal state.

    3). This issue may be caused by Windows Defender Antimalware. Please refer to the following steps to set Windows Defender Antimalware:

    Click start-> settings -> Update & Security -> Windows Defender-> click Add an exclusion under Exclusions -> click plus icon under Processes->type “devenv.exe”.

    Then restart VS to observer the run state of VS.

    4). If all above steps don’t work for you, please repair your VS and try again. The steps of repair please refer to the following step:

    Click start->control panel-> programs and features->right-click Microsoft Visual Studio VS 2015->change ->Repair.



    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Monday, August 29, 2016 5:53 AM