locked
Red X on Build node

    Question

  •  

    I am currently having a very annoying problem with Team Explorer 2008.  Everything was working fine, and today, I have a red X on every Build node.  That means I can't execute or update builds.  Note that I said "Build", and not "Builds".  Because for some reason, even the name is wrong!  Everything else works, including the interface in the Build Notification Power Toy.  The TFS Web Interface also works fine with my login.  If I login on another PC, it also works fine.  Just not working in my main development environment.  Please help!
    Thursday, April 17, 2008 1:10 PM

Answers

  • Uninstalling the power tools for TFS 2008 seems to have solved the problem.

     

    Friday, April 18, 2008 6:28 AM

All replies

  • Uninstalling the power tools for TFS 2008 seems to have solved the problem.

     

    Friday, April 18, 2008 6:28 AM
  • Which power tools release did you have installed?
    Monday, April 21, 2008 8:10 PM
    Moderator
  • I had had the power tools for TFS 2005 installed, as well as the December release for TFS 2008.  I uninstalled both.

    Tuesday, May 06, 2008 10:56 AM
  •  

    I'm having the same issue and I tried what is posted here but still did not work for me. Any ideas why.

     

    I have visual studio 05 and 08 on my box, when I open 05 everything is ok but when I open 08 the build is not accessble too, please help.

    Thursday, May 08, 2008 2:17 PM
  • I'm having the same problem, but all my partners can see the Build node except me.

     

    I'm working with VS2005. Any idea???

     

    Thanks in advance.

     

    Friday, May 09, 2008 10:53 AM
  • I am having this problem now, and I have not installed any of the power tools.  This just happened, and I have no idea why.  I uninstalled/reinstalled Team Explorer, but it makes no difference at all.

     

    Thursday, June 12, 2008 4:05 PM
  • Can you try using a different machine and see if you encounter the same problem, if this does not happen on a differenct machine then most likely your profile/account on the box is corrupted and may have to rebuild it. That's how I resolve my issue. 

     

    I posted my solution here: http://notes.arisx.com/?p=80

     

    Thursday, June 12, 2008 4:12 PM
  • Hi all,

    I found a solution, first of all you should to rename the cache folder por Team Fundation "C:\Documents and Settings\BiztalkAdmin\Local Settings\Application Data\Microsoft\Team Foundation\1.0"

     

    Then execute this command line: Start > Run : “devenv /resetuserdata".

     

    With this you reset your VS user data, you must to be care with this because you will lose all your personal options for VS, but this solve the problem for me.

     

    I hope that this can help someone.

     

    Tuesday, June 17, 2008 7:28 AM
  • Thanks Fern,

    I had the same problem but followed your instructions and now I have access to my Build node again.

    Tuesday, October 14, 2008 7:51 PM
  • I'm having the same problem, but I do not want to reset all of my personal settings. I also don't think I have power tools. Any ideas as to what causes this problem?
    Tuesday, October 27, 2009 6:44 PM
  • Sometimes, I wonder if I lose more time troubleshooting and correcting Microsoft glitches than I gain with Microsoft's product's productivity enhancements..

    One more for Ferns solution! Thanks!

    Please vote for my suggestion to add PhysicalHeightInCm and PhysicalWidthInCm to the Screen object:
    https://connect.microsoft.com/VisualStudio/feedback/details/526951/screen-object-physicalwidthincentimeters-and-physicalheightincentimeters

    Thanks.


    Jesus Christ is the saviour of all mankind.
    Tuesday, February 02, 2010 8:12 PM