locked
After reinstaling system can not start Lightswitch project start:Colud not load file or assembly system.servicemodel.domainservices.client.web Version=2.0.5.0,... RRS feed

  • Question

  • Hello,

    On Windows 8.1 an Visual studio 2013, Lightswitch projects have worked.

    After instaling new system Win 10, Visual studio 2015 , Office Toolkits, and have stucked with many issues which I solved and finnaly I get this message and nothing what I have searched on web did not help.

    The error is : Could not load file or assembly 'System.ServiceModel.DomainServices.Client.Web, Version 2.05.0, Culture = neutral, PublicKeyToken =.....

    .... The system cannot find the file specified... 


    • Edited by MufidH Tuesday, January 26, 2016 1:28 AM
    Tuesday, January 26, 2016 1:27 AM

Answers

  • Hi MufidH,

    According to the error message, please add the reference from %ProgramFiles(x86)%\Microsoft SDKs\RIA Services\v1.0\Libraries\Silverlight\System.ServiceModel.DomainServices.Client.Web.dll.

    Then please clean your LightSwitch projects and rebuild it again.

    In addition, your project is created by VS2013, but you open it with VS2015, which means it has been upgraded. So please refer to following link to check your project, whether it upgraded correctly.

    https://msdn.microsoft.com/en-us/library/hh674025.aspx

    Best Regards,
    Weiwei

    • Marked as answer by MufidH Wednesday, January 27, 2016 12:14 AM
    Tuesday, January 26, 2016 8:43 AM
    Moderator

All replies

  • Hi MufidH,

    According to the error message, please add the reference from %ProgramFiles(x86)%\Microsoft SDKs\RIA Services\v1.0\Libraries\Silverlight\System.ServiceModel.DomainServices.Client.Web.dll.

    Then please clean your LightSwitch projects and rebuild it again.

    In addition, your project is created by VS2013, but you open it with VS2015, which means it has been upgraded. So please refer to following link to check your project, whether it upgraded correctly.

    https://msdn.microsoft.com/en-us/library/hh674025.aspx

    Best Regards,
    Weiwei

    • Marked as answer by MufidH Wednesday, January 27, 2016 12:14 AM
    Tuesday, January 26, 2016 8:43 AM
    Moderator
  • Thank you Weiwei,

    It helped, but I could not find file in directory you proposed then in

    Users\user_name\.nuget\packages\RIAServices.Silverlight\4.2.0\lib\sl40

    Later, it also asked for System.ServiceModel.DomainServices.Client.dll and I also add it as reference.

    It Works!!!

    Thanks again:)

    Wednesday, January 27, 2016 12:14 AM