none
Exchange 2010 transition to New 2010 Install RRS feed

  • Question

  • Hello,

    I have migrated to a new Exchange 2010 install.  However, while trying to uninstall 2010 Exchange from the old server it fails on public folders.  I have checked that there are no public folders on the old server but the old install insists there are.  Ihave looked at ADSI edit and the old server isn't listed.  I want to decommission this server but want to make sure if I do so it doesn't break everything.

    Any help would be greatly appreciated.


    Monday, May 19, 2014 8:29 PM

Answers

  • Do you see Public Folder Database 0628661045 at the below path via ADSIEdit? If yes, can you see where it is located via msExchMasterServerOrAvailabilityGroup attribute.

    CN=Databases,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=EXOrgName,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=com

    It is not recommended and supported to update or delete this object via ADSIEdit but I don't know what to do here, if an entry of the old server is present in AD then I would have recommended you to install the server back via /recoverserver switch, move the public folders from the PF database and uninstall the server normally which is the supported way.

    Blog: http://exchangeshare.wordpress.com/

    • Marked as answer by WLS-ITGuy Tuesday, May 20, 2014 5:16 PM
    Tuesday, May 20, 2014 2:42 PM
    Moderator

All replies

  • Can you post the error what you are getting when you try to uninstall?

    What do you see when you run Get-PublicFolderDatabase & Get-ExchangeServer cmdlets?

    Remove Public Folder Databases


    Blog: http://exchangeshare.wordpress.com/

    Monday, May 19, 2014 11:30 PM
    Moderator
  • Here is the error from the uninstall:

    Uninstall cannot continue. Database 'Public Folder Database 0628661045': The public folder database "Public Folder Database 0628661045" contains folder replicas. Before deleting the public folder database, remove the folders or move the replicas to another public folder database. For detailed instructions about how to remove a public folder database, see http://go.microsoft.com/fwlink/?linkid=81409&clcid=0x409.

    Click here for help... http://go.microsoft.com/fwlink/?linkid=30939&l=en&v=ExBPA.14&id=b6e3b32a-8848-46cb-9567-72288ac15f60

    Elapsed Time: 00:00:06

    I followed the instructions on the link and have even followed the steps on here.  http://exchangeserverpro.com/exchange-2010-remove-public-folder-database/

    and get an error that there are no public folders in '\'.  While looking in ADSIEdit the old exchange box isn't even listed.
    Tuesday, May 20, 2014 12:08 PM
  • However, public folders are listed in my OUtlook connection but when I try to get to them I get this error:

    WLS-Exchange is the new Server and W2K8Mail is the old server.

    Tuesday, May 20, 2014 1:11 PM
  • Do you see Public Folder Database 0628661045 at the below path via ADSIEdit? If yes, can you see where it is located via msExchMasterServerOrAvailabilityGroup attribute.

    CN=Databases,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=EXOrgName,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=com

    It is not recommended and supported to update or delete this object via ADSIEdit but I don't know what to do here, if an entry of the old server is present in AD then I would have recommended you to install the server back via /recoverserver switch, move the public folders from the PF database and uninstall the server normally which is the supported way.

    Blog: http://exchangeshare.wordpress.com/

    • Marked as answer by WLS-ITGuy Tuesday, May 20, 2014 5:16 PM
    Tuesday, May 20, 2014 2:42 PM
    Moderator
  • If I go to CN=Configuration, CN=Services, CN-WLS-Exchange, CN=Adminnistrative Groups, CN=Exchange Administrative Group, CN=Databases.  CN=Public Folder Database 0628661045 is listed and "associated" on W2K8Mail.

    Unless I am reading something wrong, when I go to ADSIEdit I don't see the path that you listed.

    Tuesday, May 20, 2014 4:58 PM
  • No, you are at the correct path. Did you have any data in the public folder? if not, let's remove Public Folder Database 0628661045 and try to uninstall...


    Blog: http://exchangeshare.wordpress.com/

    Tuesday, May 20, 2014 5:08 PM
    Moderator
  • Boom That did it!  

    Finally I can put this thing to bed!

    Thanks Tank!

    Tuesday, May 20, 2014 5:17 PM
  • Awesome, you're welcome!

    Blog: http://exchangeshare.wordpress.com/

    Tuesday, May 20, 2014 5:24 PM
    Moderator