Visual Studio Android Emulator is useless as it literally burns my CPU


  • I've the same problem as these guys:


    Setup: Windows 10 Anniversary Update + latest standalone Visual Studio Android Emulator

    The XDE.exe process burns my CPU. With water cooling the temperature goes to 60 degrees constant. Even WatchDogs 2 doesn't use that much CPU.

    DO SOMETHING PLEASE! Else I will stop using Hyper-V and install VMWARE Workstation.

    You made this Standalone Android Emulator so that people can use it with Hyper-V as google's emulator only works if you disable Hyper-V.

    But this Standalone Android Emulator is a dud. I cannot code for long if my CPU is burning up.

    Friday, April 28, 2017 4:50 PM

All replies

  • Hi Gaurav Bhandarkar,

    Welcome to the MSDN forum.

    Sorry for this inconvenience and thank you for your feedback.

    Refer to your description, please check this similar issue: Why doesn't Visual Studio Emulator for Android launch anymore? and have a try with the following:

    1. Delete all virtual switches: Go to Hyper-V Manager, and delete all virtual switches via the Virtual Switch Manager 2) In Hyper-V Manager, delete all VMs. 3) Restart the computer. 4) Start an emulator.
    2. Disable network interfaces: disable the network interfaces except the windows phone switch. Then once the emulator is booted, turn it back on. If you delete them Xde will recreate them, you want them created but disabled in the control panel. The only thing to leave enabled is the windows phone one.
    3. Reinstall the Visual Studio Emulator for Android

    Best regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact

    Monday, May 01, 2017 9:16 AM