locked
Error 500. RRS feed

  • Question

  • User1150832288 posted

    Hi,

    I download and  installed a Non Thread Safe PHP and Visual C++ redistributable  2015-2019. Unzipped and extracted all the php files into C:/PHP directory. Followed all the instructions using Microsoft website and a youtube video by Robert Mayer

    " How to install PHP in Microsoft IIS7 and later".  Created a simple test file Phpinfo.php and saved in wwwroot directory in C drive.

    I typed the following into the address bar of the browser:

    Http://localhost/Phpinfo.php.

    However I get the 500 error message with detail description:

    <fieldset>

    HTTP Error 500.0 - Internal Server Error

    <handler> scriptProcessor could not be found in <fastCGI> application configuration

    </fieldset>
    <fieldset><legend>Detailed Error Information</legend>
    Module FastCgiModule
    Notification ExecuteRequestHandler
    Handler PHP_FastCGI
    Error Code 0x80070585
    Requested URL http://localhost:80/Phpinfo.php
    Physical Path C:\inetpub\wwwroot\Phpinfo.php
    Logon Method Anonymous
    Logon User Anonymous
    </fieldset>
    <fieldset><legend>Most likely causes:</legend>
    • IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred.
    • IIS was not able to access the web.config file for the Web site or application. This can occur if the NTFS permissions are set incorrectly.
    • IIS was not able to process configuration for the Web site or application.
    • The authenticated user does not have permission to use this DLL.
    • The request is mapped to a managed handler but the .NET Extensibility Feature is not installed.
    </fieldset>
    <fieldset><legend>Things you can try:</legend>
    • Ensure that the NTFS permissions for the web.config file are correct and allow access to the Web server's machine account.
    • Check the event logs to see if any additional information was logged.
    • Verify the permissions for the DLL.
    • Install the .NET Extensibility feature if the request is mapped to a managed handler.
    • Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here.
    • The CGI is checked in IIS 7 setup. I don't know why I am getting this error.
    • Please help.
    • Thx.
    •     SghamII7
    </fieldset>
    Monday, September 7, 2020 9:54 PM

Answers

  • User-848649084 posted

    Hi,

    Instaling Php using the web platform installer is a good option and convenient. you do not need to do any configuration after installing it.

    and for manual installation error you could check that you configure pho fast CGI setting as shown below:

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, September 8, 2020 6:48 AM
  • User-848649084 posted

    PHP 7.4 should not depend on 5.2.28. You could post the installation log so that I can help you find the reason. You could find the error log in: C:\Users\Administrator\AppData\Local\Microsoft\Web Platform Installer\logs\webpi.

    No need to worry about it. your iis will use the 7.4 PHP version.you can check by using the phpinfo page. 

    and PHP manager for iis and cache extension is not necessary to run PHP in iis. so you can ignore this error.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, September 9, 2020 2:15 AM
    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, September 11, 2020 2:57 AM
  • User1150832288 posted

    HI

    I think I finally fixed it.

    I changed the following in php.ini:

    From extension_dir= c:\program files\php\exe  to extension_dir = "C:\PHP\V7.4\ext\

    Added a FastCGI Setting to C:\PHP\V7.4\php-cgi.exe

    Added a handler mapping  *.php

    Now that I entered http://localhost/phpinfo.php  in the address bar i get the following page showing all the setting.

    I assume that is working now. Right?.

    The only issue right now is that I get :iisreset is not recognized  as an internal or external command at the command prompt.

    **this command use to work until two days ago**.

    Also , tonight,  when tried to open the phpinfo.php at command prompt, it said "access denied."

    Thx.

            SghamII7

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, September 11, 2020 3:53 AM
  • User-848649084 posted

    Hi Shervin,

    do you have administrator rights? from your command prompt screenshot, I can see that you are still under the user folder in which you run the cmd as administrator.

    when you run the cmd as administrator it will open the folder 'C:\Windows\System32'.

    the other way you could try run cmd as administrator and go to the 'C:\Windows\System32' and run iisreset command.

    you could also try to search for the iisreset.exe on  Start Menu and run as administrator.

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, September 17, 2020 2:01 AM
  • User-848649084 posted

    yes this is the default behavior you need to run cmd as administrator.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, September 17, 2020 2:44 AM

All replies

  • User690216013 posted

    Can you run a report and see what it says?

    https://docs.jexusmanager.com/tutorials/php-diagnostics.html

    Monday, September 7, 2020 11:16 PM
  • User-848649084 posted

    Hi,

    Instaling Php using the web platform installer is a good option and convenient. you do not need to do any configuration after installing it.

    and for manual installation error you could check that you configure pho fast CGI setting as shown below:

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, September 8, 2020 6:48 AM
  • User1150832288 posted

    Hi Jalpa,

    I reinstalled the PHP this time using the Web Platform installer.

    However it did not install all the components I need like php Manager for IIS and Windows cache extension 2.0.

    Aren't those two needed along with the application itself?

    I don't know why it installed PHP 5.3.28 along with version 7.4.

    What should I do?.  Please help.

    Thx.

               SghamII7

    Wednesday, September 9, 2020 2:06 AM
  • User-848649084 posted

    PHP 7.4 should not depend on 5.2.28. You could post the installation log so that I can help you find the reason. You could find the error log in: C:\Users\Administrator\AppData\Local\Microsoft\Web Platform Installer\logs\webpi.

    No need to worry about it. your iis will use the 7.4 PHP version.you can check by using the phpinfo page. 

    and PHP manager for iis and cache extension is not necessary to run PHP in iis. so you can ignore this error.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, September 9, 2020 2:15 AM
  • User1150832288 posted

    Hi,

    There is no Web Platform Installer\logs\webpi in Microsoft folder.

    Here is the path to Web Platform Installer in my PC:

    C;\Program files\Microsoft\Web Platform Installer.

    I even tried to find it by using CMD. But I could not such sub directory.

    Also I deleted PHP 5.3.28.  I only have PHP 7.4.1 now in C:\PHP .

    After I create the test file I will save in wwwroot directory in C drive.

    Is this the right url to open phpinfo.php in the address bar?

    C:\inetpub\wwwroot\phpinfo.php

    or

    Http:\\localhost\phpinfo.php

    Thx.

              Shervin

    Wednesday, September 9, 2020 3:24 AM
  • User-848649084 posted

    try to access the page using  

    Http:\\localhost\phpinfo.php

    Wednesday, September 9, 2020 7:37 AM
  • User1150832288 posted

    Hi,

    I get a blank page if I enter the following in the address bar:

    file:///C:/inetpub/wwwroot/phpinfo.php.

    Also I got the same error message as i did before typing the following in the address bar.

    Http://localhost/phpinfo.php

    It does not matter how i install the php, either manually or using web platform installer,  i get the

    same error message. 

    There is no setting also for FastCGI Setting after installing.

    Also I don't see any .php handler after installing the PHP.

    Why do I get the same error message everytime? What am i missing.  I installed Active Perl really easy with no

    problem unlike PHP.  Kindly help me with this error message.

    Thx.

                   SghamII7

    Friday, September 11, 2020 1:40 AM
    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, September 11, 2020 2:57 AM
  • User1150832288 posted

    HI

    I think I finally fixed it.

    I changed the following in php.ini:

    From extension_dir= c:\program files\php\exe  to extension_dir = "C:\PHP\V7.4\ext\

    Added a FastCGI Setting to C:\PHP\V7.4\php-cgi.exe

    Added a handler mapping  *.php

    Now that I entered http://localhost/phpinfo.php  in the address bar i get the following page showing all the setting.

    I assume that is working now. Right?.

    The only issue right now is that I get :iisreset is not recognized  as an internal or external command at the command prompt.

    **this command use to work until two days ago**.

    Also , tonight,  when tried to open the phpinfo.php at command prompt, it said "access denied."

    Thx.

            SghamII7

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, September 11, 2020 3:53 AM
  • User-848649084 posted

    I assume that is working now. Right?.

    yes, it's working now.

    The only issue right now is that I get :iisreset is not recognized  as an internal or external command at the command prompt.

    try to run the command prompt as administrator and run this command.

    Friday, September 11, 2020 5:58 AM
  • User1150832288 posted

    Hi Jalpa,

    It does not work as an administrator either.

    Please look at attachment below.

    Right now the only way it work is for me to type iisreset next to Run in start menu.

    I think the path is missing in System variables -Enviornment variables.

    I have to add the path.  I don't know what it is though.

    Thx.

                     Shervin

    Friday, September 11, 2020 11:46 PM
  • User-848649084 posted

    could you please share which iis features you installed? 

    below is my side result:

    Wednesday, September 16, 2020 9:34 AM
  • User1150832288 posted

    Hi Jalpa,

    Please see the attachment.

    Thx.

        Shervin

    Thursday, September 17, 2020 1:32 AM
  • User-848649084 posted

    Hi Shervin,

    do you have administrator rights? from your command prompt screenshot, I can see that you are still under the user folder in which you run the cmd as administrator.

    when you run the cmd as administrator it will open the folder 'C:\Windows\System32'.

    the other way you could try run cmd as administrator and go to the 'C:\Windows\System32' and run iisreset command.

    you could also try to search for the iisreset.exe on  Start Menu and run as administrator.

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, September 17, 2020 2:01 AM
  • User1150832288 posted

    Hi Jalpa,

    Yes I am the only user of this desktop and have administrator access.

    I ran the cmd as an administrator and it work just like you said.

    But if i am as a user with admin access  it won't work

    Thx

               Shervin

    Thursday, September 17, 2020 2:30 AM
  • User-848649084 posted

    yes this is the default behavior you need to run cmd as administrator.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, September 17, 2020 2:44 AM
  • User-848649084 posted

    From your post I can see that your issue is resolved  I request you to mark the helpful suggestion as an answer. This will help other people who face the same issue.

    If your issue still exists then try to refer the solution given by the community members.

    If then also you have any further questions then let us know about it.

    We will try to provide further suggestions to solve the issue.

    Thanks for your understanding.

    Regards

    Jalpa.

    Thursday, September 17, 2020 2:54 AM
  • User1150832288 posted

    will do.

    Thx.

          shervin

    Thursday, September 17, 2020 3:17 AM