locked
reportviewer control does not show parameter prompt properly in an aspx page RRS feed

  • Question

  • I have a web application in vs 2005. I draw and drop a report reviewer control to an aspx page, which is a content page with reference to master page. I set the smart tag perperty to "Server Report", set the report server url to http://localhost/reportserver; Report path to "/FysbReports/Report1"

     

    Here is the code:

    <%@ Page Language="C#" MasterPageFile="~/FysbReviewer.master" AutoEventWireup="true" CodeFile="ReportsMenu.aspx.cs" Inherits="ReportsMenu" Title="Report Menu" %>

    <%@ Register Assembly="Microsoft.ReportViewer.WebForms, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
        Namespace="Microsoft.Reporting.WebForms" TagPrefix="rsweb" %>
    <asp:Content ID="Content3" ContentPlaceHolderID="ContentPlaceHolder3" Runat="Server">
    <rsweb:ReportViewer ID="ReportViewer1" runat="server" style="positionTongue Tiedtatic" ShowParameterPrompts="true"
            Font-Names="Verdana" Font-Size="8pt" Height="800px" ProcessingMode="Remote" Width="100%">
            <ServerReport ReportPath="/FysbReports/Report1" />
        </rsweb:ReportViewer>
    </asp:Content>

     

    The aspx page loads fine, only that the report parameter prompt does not work!

     

    If I do the same thing in a plain page without master/content pages, the report loads just fine with the proper parameter prompt!

     

    Any ideas? Thanks,

    Friday, November 2, 2007 7:34 PM

All replies