none
Visual Studio 2015 installation fails at Team Explorer Module RRS feed

  • Question

  • Hey,

    So I am getting the same error as various other people in the thread when trying to install Visual Studio 2015. It installed successfully the first time but when I'm trying to reinstall it now it is failing. As it seems from the threads, it is an issue enough people are facing. Can you please look into this? I've tried the various steps mentioned in the threads below : disabling AV, deleting %Temp%, running as admin, SFC scan etc. etc. Here's the failure log from installation below :

    [169C:0B90][2015-11-21T22:05:48]i000: MUX:  ExecutePackageBegin PackageId: vs_teamExplorerCore
    [0CEC:0610][2015-11-21T22:05:48]i301: Applying execute package: vs_teamExplorerCore, action: Install, path: C:\ProgramData\Package Cache\{791295AE-3B0A-3222-9E69-26C8C106E8D1}v14.0.23102\packages\TeamExplorer\Core\vs_teamExplorerCore.msi, arguments: ' MSIFASTINSTALL="7" USING_EXUIH="1"'
    [169C:0B90][2015-11-21T22:07:07]i000: MUX:  ExecuteError: Package (vs_teamExplorerCore) failed: Error Message Id: 1722 ErrorMessage: There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. 
    [0CEC:0610][2015-11-21T22:08:04]e000: Error 0x80070643: Failed to install MSI package.
    [0CEC:0610][2015-11-21T22:08:04]e000: Error 0x80070643: Failed to execute MSI package.
    [169C:0B90][2015-11-21T22:08:04]e000: Error 0x80070643: Failed to configure per-machine MSI package.
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  Installation size in bytes for package: vs_teamExplorerCore MaxAppDrive: 0  MaxSysDrive: 329060352  AppDrive: 0  SysDrive: 0
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  Return Code:0x80070643 Msi Messages:There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.   Result Detail:0 Restart:None
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  Set Result: Return Code=-2147023293 (0x80070643), Error Message=There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  , Result Detail=, Vital=True, Package Action=Install, Package Id=vs_teamExplorerCore
    [169C:0B90][2015-11-21T22:08:04]i000: Setting string variable 'BundleResult' to value '1603'
    [169C:0B90][2015-11-21T22:08:04]i319: Applied execute package: vs_teamExplorerCore, result: 0x80070643, restart: None
    [169C:0B90][2015-11-21T22:08:04]e000: Error 0x80070643: Failed to execute MSI package.
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  ExecutePackageBegin PackageId: vs_teamExplorerCore
    [0CEC:0610][2015-11-21T22:08:04]i318: Skipped rollback of package: vs_teamExplorerCore, action: Uninstall, already: Absent
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  Installation size in bytes for package: vs_teamExplorerCore MaxAppDrive: 0  MaxSysDrive: 0  AppDrive: 0  SysDrive: 0
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  Return Code:0x0 Msi Messages:There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.   Result Detail:0 Restart:None
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  Reset execution Result
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  Reset Result
    [169C:0B90][2015-11-21T22:08:04]i000: Setting string variable 'BundleResult' to value '1603'
    [169C:0B90][2015-11-21T22:08:04]i319: Applied rollback package: vs_teamExplorerCore, result: 0x0, restart: None
    [0CEC:0610][2015-11-21T22:08:04]i351: Removing cached package: vs_teamExplorerCore, from path: C:\ProgramData\Package Cache\{791295AE-3B0A-3222-9E69-26C8C106E8D1}v14.0.23102\
    [0CEC:0610][2015-11-21T22:08:04]i372: Session end, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{50b32652-69d2-4b93-9316-edcd12067b8b}, resume: ARP, restart: None, disable resume: No
    [0CEC:0610][2015-11-21T22:08:04]i371: Updating session, registration key: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{50b32652-69d2-4b93-9316-edcd12067b8b}, resume: ARP, restart initiated: No, disable resume: No
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  Apply Complete: Disk Space Used in bytes for Installation:  MaxAppDrive: 0  MaxSysDrive: 404221952  AppDrive: 0  SysDrive: 25194496
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  Free Disk Space after install:  SystemDrive C:\ 7050801152 bytes  AppDrive C:\ 7050801152 bytes
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  Go to Finished page.
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  Watson Bucketting Parameters
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  P1 - vs_community
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  P2 - 14.0.23107.10
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  P3 - 14.0.23107
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  P4 - Install
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  P5 - Team Explorer for Microsoft Visual Studio 2015
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  P6 - Install
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  P7 - 0x80070643
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  P8 - There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. 
    [169C:0B90][2015-11-21T22:08:04]i000: MUX:  P9 -
    [169C:0B90][2015-11-21T22:08:04]i399: Apply complete, result: 0x80070643, restart: None, ba requested restart:  No

    Saturday, November 21, 2015 10:30 PM

Answers

  • Hi ar0ra.palindrome,

    Thank you for posting in MSDN forum.

    I found the error code “0x80070643”, it means “Fatal error during installation”, this is a general error and most of the time, it means that your package was corrupted.
     
    Refer to: https://support.microsoft.com/en-us/kb/2899270#bookmark-iso 0x80070643 means installation cache or ISO is corrupted, it is for visual studio 2013, and in visual studio 2015, this error code means the package is corrupted most of the time.

    So I suggest you could install it from the ISO image, you can download it from here.

    Before installing, we need to make sure that the package is not corrupted, Please use FCIV.exe http://support.microsoft.com/kb/841290 to verify hash of the ISO. Any discrepancy would indicate that the file was corrupted. Here is a blog for how to use it, you can refer to it.

    The SHA-1 value of visual studio 2015 community is "BAAD3CEBAB7A5834D8F78F7D02E4880C010F3BA9".

    Please make sure that your SHA-1 value is correct.

    Best Regards,

    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, November 23, 2015 2:46 AM
    Moderator

All replies

  • Anyone with any solution other than to re-install windows? Thanks.
    Sunday, November 22, 2015 2:43 PM
  • Hi ar0ra.palindrome,

    Thank you for posting in MSDN forum.

    I found the error code “0x80070643”, it means “Fatal error during installation”, this is a general error and most of the time, it means that your package was corrupted.
     
    Refer to: https://support.microsoft.com/en-us/kb/2899270#bookmark-iso 0x80070643 means installation cache or ISO is corrupted, it is for visual studio 2013, and in visual studio 2015, this error code means the package is corrupted most of the time.

    So I suggest you could install it from the ISO image, you can download it from here.

    Before installing, we need to make sure that the package is not corrupted, Please use FCIV.exe http://support.microsoft.com/kb/841290 to verify hash of the ISO. Any discrepancy would indicate that the file was corrupted. Here is a blog for how to use it, you can refer to it.

    The SHA-1 value of visual studio 2015 community is "BAAD3CEBAB7A5834D8F78F7D02E4880C010F3BA9".

    Please make sure that your SHA-1 value is correct.

    Best Regards,

    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, November 23, 2015 2:46 AM
    Moderator
  • Hi,

    You can check the following sollution: 
    .../questions/33855177/multiple-errors-installing-visual-studio-2015-community-edition/33881460#33881460
    instead of "..." put stackoverflow site.

    Looks like in Visual Studio installer packeges are mixed some redistributable components.

    Try to remove the x86 part of redistributable C++ library and install it separately. 

    You can download it from microsoft site. https://www.microsoft.com/en-us/download/details.aspx?id=48145

    • Proposed as answer by Islam Mohamed Sunday, March 20, 2016 11:25 AM
    • Unproposed as answer by Islam Mohamed Sunday, March 20, 2016 11:25 AM
    Friday, November 27, 2015 6:42 AM
  • this worked successfully with me .. thanks man
    Sunday, March 20, 2016 11:26 AM