none
BizTalk Server 2009 -HIPAA configuring a party issues RRS feed

  • Question

  • Hi,
    I have to send a HIPAA 837 file as an output of my process. Since it needs to have the party details like ISA and GS segments, i have to configure the party for the same. Since this is a process where i would be sending a EDI file do i need to configur party as a Interchange Sender?

    If so, the various values in ISA say ISA02 and ISA04- I could not specify it while configuring the party, even though their values are just spaces...What am i supposed to do?

    Other Interchange items like ISA09,ISA10,ISA11 to ISA16 ...I'm not able to see these properties , so I could not configure them.

    For the functional identifier like GS, I have to configure the values from GS01 to GS08...Again, I'm not able to see those properties How can I configure them?

    Your help is appreciated!

    Thanks,

    Ram
    Wednesday, November 4, 2009 1:08 AM

Answers

  • Hi

    I believe that your problem is that you are not familiar with X12 as well as the BT party configuration.

    You fill in the sender properties with your information, and then for the party to whom you are sending the transaction you fill in the receiver properties.

    The ISA segment is the only fixed length segment in X12.  Because it is fixed length, many of the elements are not configurable.  For example, the ISA09 and ISA10 date and time elements -- they are not configurable because the standards only allow one format for each.  You cannot change their format -- thus BT will automatically fill them in for you.  The ISA01, 02, 03, & 04 fields are security fields.  Unless you are going to have actual security data, these should be left alone.  Again, BT will automatically fill in the spaces that you need.   You must fill in the ISA05, 06, 07, and 09 fields with the sender/receiver qualifiers and ID's.  You must also check the ISA11 box if you want the ISA11 to contain a repetition separator. 

    On the receiver side, you must set the ISA11, 12, 13, 14, and 15 to match your trading partner's requirements.  You also set the separators and terminators to meet the trading partner requirements.

    As you noted, the GS elements are fully configurable for the receiver.  This is because you must meet your trading partner's requirements for the contents and content formats for the GS.

    Finally, note that you do not need to configure the separators, terminators, or GS elements for the home party (you).  The engine figures out what these values are when it parses the incoming GS.

    Hope this helps,


    Jim -- Pro Mapping in BizTalk 2009, Apress Books, March 23, 2009
    • Marked as answer by Ram36 Thursday, November 5, 2009 4:39 AM
    Thursday, November 5, 2009 2:48 AM

All replies

  • Hi,
       These all properties are in Edi Properties of Party.

    Please check following in your Biztalk installation:
    1- Biztalk is properly configured, Make sure that Biztalk Edi/As2 runtime is configured.
    2- Go to Party node in the Biztalk Admin Console.
    3- Right click and create new party. Then give a name to it and save it.
    4- Then right click on this party and click on "Edi Properties".Then it's EDI properties window will pop up.
    5- Then go to X12 properties. And click on Party as receiver.
    6- In this you can find Interchange header page and Group header pages. There you can see all the settings for ISA and GS.

    I think you are not familier with the Edi Party settings in Biztalk. You should first go through following tutorial:
    http://msdn.microsoft.com/en-us/library/bb226541(BTS.10).aspx



    Thanks
    Gyan
    If this answers your question, please mark it as "Answered".
    Wednesday, November 4, 2009 5:43 PM
  • Hi,
    I'm able to see that EDI/AS2 is configured in my development server. I created a new party and went through its EDI properties...the question here is since I'm a sender of a 837 file...do I need to go to the party as interchange sender? please confirm on this, as I'm not sure whether it has to be a sender properties or receiver properties, as I'm sending the HIPAA, my guess would be sender properties. If I have to use the interchange receiver properties, please explain why it has to be?

    If I have to configure the Interchange Party as a receiver, I have to specify some value for ISA02, the field is disabled - I just wanted some spaces in that field. Similarly I have to have some spaces for ISA04, how can I achieve them?

    Also, I could not see the Interchange Items ISA09 and ISA10 they need to have the Date and time respectively in the format YYMMDD and HHMM. How can I provide them?

    I guess I understood the functional header (GS) part, if I have to configure as receiver.

    Thanks,


    Ram
    Wednesday, November 4, 2009 7:27 PM
  • Hi

    I believe that your problem is that you are not familiar with X12 as well as the BT party configuration.

    You fill in the sender properties with your information, and then for the party to whom you are sending the transaction you fill in the receiver properties.

    The ISA segment is the only fixed length segment in X12.  Because it is fixed length, many of the elements are not configurable.  For example, the ISA09 and ISA10 date and time elements -- they are not configurable because the standards only allow one format for each.  You cannot change their format -- thus BT will automatically fill them in for you.  The ISA01, 02, 03, & 04 fields are security fields.  Unless you are going to have actual security data, these should be left alone.  Again, BT will automatically fill in the spaces that you need.   You must fill in the ISA05, 06, 07, and 09 fields with the sender/receiver qualifiers and ID's.  You must also check the ISA11 box if you want the ISA11 to contain a repetition separator. 

    On the receiver side, you must set the ISA11, 12, 13, 14, and 15 to match your trading partner's requirements.  You also set the separators and terminators to meet the trading partner requirements.

    As you noted, the GS elements are fully configurable for the receiver.  This is because you must meet your trading partner's requirements for the contents and content formats for the GS.

    Finally, note that you do not need to configure the separators, terminators, or GS elements for the home party (you).  The engine figures out what these values are when it parses the incoming GS.

    Hope this helps,


    Jim -- Pro Mapping in BizTalk 2009, Apress Books, March 23, 2009
    • Marked as answer by Ram36 Thursday, November 5, 2009 4:39 AM
    Thursday, November 5, 2009 2:48 AM
  • That helps a lot!! Thanks!
    Ram
    Thursday, November 5, 2009 4:39 AM