locked
RenderTransform problem in Blend 3 RRS feed

  • Question

  • Hello,

    I'm trying to use an existing xaml file and edit it in Blend 3 but I have some problems with the RenderTransform property for some elements.

    As you can see, in the Kaxaml editor (link to a screen capture below) the drawing looks great and the objects are well positionning:
    http://screencast.com/t/NTYwZmI4

    But that's not the case in Blend 3 (see the red rectangles):
    http://screencast.com/t/MWUyOTI5

    Blend seems not to like the RenderTransform property (it's the first time i see this kind of notation for the value of this property) at design time. But when I run the project, the application looks like the render in Kaxaml.

    Do you have a idea of what the problem can be (and what the values in the RenderTransform propery meens) ?

    Saturday, January 9, 2010 10:38 AM

Answers

  • Hi,

    It seems like that Expression Blend doesn't recognize the matrix defined in RenderTransform. Try to use something like below code and it works in Expression Blend:

    <Canvas>
        <Canvas.RenderTransform>
            <MatrixTransform Matrix="2,0,0,1,0,0"></MatrixTransform>
        </Canvas.RenderTransform>
    </Canvas>

     And to answer your second question, the values in the RenderTransform specifies the matrix which is used to perform transform, for more information on this, please refer to this article:

    http://blogs.msdn.com/jstegman/archive/2006/04/02/566939.aspx

    Sunday, January 10, 2010 9:19 PM