locked
SPD 2007 Send Email does not send with condition added RRS feed

  • Question

  • I am writing my first SPD 2007 custom approval workflow.  Basically I would like to notify up to 3 approvers when the status of the form equal 1 (first approver), 2 (2nd approver) or 3 (3rd approver) (if status = 1, sendEmail to First Approver and so on).

    If new form,  submit button is clicked, it sets status to 1 so it should go that the 1st condition (status = 1)  is true and workflow should send email.  It doesn't.  If I remove the condition, the email will send.

    The approvers are predetermined in the form, the form field is  promoted column to determine where to send the email.  This is working.

    What other conditions do I need to make this happen?  I have set workflow to begin when a new item is added and if a change is made.  When the 2nd approver clicks Approved, the status is changed to 2 and so on so the status is changed with button clicks.....

    Please help!  I know this should be simple. :(


    dms

    Thursday, March 8, 2012 8:53 PM

Answers

  • Can you give a little information as to what you're doing.

    When you say "form" do you mean an InfoPath form? It sounds like that's what you're doing, but that's not clear.

    It sounds like your Status field is a promoted field, correct? If so, have you tried using the Log to History action to display the value in this status field?


    Planet Technologies || SharePoint Task Force

    Friday, March 9, 2012 5:19 AM