locked
MDS WCF issue after upgrading from MDS 2012 to MDS 2016 RRS feed

  • Question

  • Hi,

    We have web service that consumes MDS WCF and enables methods to insert , update entities for the MDS model. Recently we upgraded from MDS 2012 to MDS 2016. Now when we try to run the web service, we get the below error message -

    "The formatter threw an exception while trying to deserialize the message: There was an error while trying to deserialize parameter http://schemas.microsoft.com/sqlserver/masterdataservices/2009/09:EntityMembers. The InnerException message was 'Invalid enum value 'Access' cannot be deserialized into type 'mymdswcfservice.SecurityPermission'. Ensure that the necessary enum values are present and are marked with EnumMemberAttribute attribute if the type has DataContractAttribute attribute.'. 

    We have tried to debug this error, but its getting generated at one of MDS WCF methods  - 'EntityMembersGet' and unable to debug this MDS WCF method. Also tried to disable service configuration 'Reuse Type in referenced assembles', but it did not help.

    How to fix this?

    Thanks

    Wednesday, August 1, 2018 1:04 PM

All replies