none
Security:System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at... RRS feed

  • Question

  • Greetings all.
    I am at wit's end. This service was working and now it is not.

    Here is service model from services web.config:
    <system.serviceModel>
    <client />
    <bindings>
    <wsHttpBinding>
    <binding name="wsBinding" transactionFlow="true" maxBufferPoolSize="2147483647"
    maxReceivedMessageSize="2147483647">
    <security mode="TransportWithMessageCredential" />
    </binding>
    </wsHttpBinding>
    </bindings>
    <services>
    <service behaviorConfiguration="com.sti.ib.Framework.SOA.SOAServicesBehavior" name="com.sti.ib.Framework.SOA.SOAServices">
    <endpoint address="https://223.1.1.21/AllSOAsrp/SOAServices.svc" binding="wsHttpBinding" bindingConfiguration="wsBinding" contract="com.sti.ib.Framework.SOA.ISOAServices">
    </endpoint>
    <endpoint address="mex" binding="mexHttpBinding" contract="IMetadataExchange"/>
    </service>
    </services>
    <behaviors>
    <serviceBehaviors>
    <behavior name="com.sti.ib.Framework.SOA.SOAServicesBehavior">
    <serviceMetadata httpGetEnabled="false" httpsGetEnabled="true"/>
    <serviceDebug includeExceptionDetailInFaults="true"/>
    <serviceThrottling
    maxConcurrentCalls="5000"
    maxConcurrentSessions="5000"
    maxConcurrentInstances="5000"
    />
    </behavior>
    </serviceBehaviors>
    </behaviors>
    </system.serviceModel>

    Here is service model from web application web.config:
    <system.serviceModel>
    <bindings>
    <wsHttpBinding>
    <binding name="WSHttpBinding_ISOAServices" closeTimeout="00:01:00"
    openTimeout="00:01:00" receiveTimeout="00:10:00" sendTimeout="00:01:00"
    bypassProxyOnLocal="false" transactionFlow="false" hostNameComparisonMode="StrongWildcard"
    maxBufferPoolSize="2147483647" maxReceivedMessageSize="2147483647" messageEncoding="Text"
    textEncoding="utf-8" useDefaultWebProxy="true" allowCookies="false">
    <readerQuotas maxDepth="32" maxStringContentLength="2147483647" maxArrayLength="2147483647"
    maxBytesPerRead="2147483647" maxNameTableCharCount="2147483647" />
    <reliableSession ordered="true" inactivityTimeout="00:10:00"
    enabled="false" />
    <security mode="TransportWithMessageCredential">
    <transport clientCredentialType="None" proxyCredentialType="None"
    realm="" />
    <message clientCredentialType="Windows" negotiateServiceCredential="true"
    algorithmSuite="Default" />
    </security>
    </binding>
    </wsHttpBinding>
    </bindings>
    <client>
    <endpoint address="https://223.1.1.21/AllSOAsrp/SOAServices.svc"
    binding="wsHttpBinding" bindingConfiguration="WSHttpBinding_ISOAServices"
    contract="ServiceReference1.ISOAServices" name="WSHttpBinding_ISOAServices" />
    </client>
    </system.serviceModel>

    I have tried to remove the service reference and re-add it, however, it will not let me if I attempt to use the https address. It will let me if I use the http address.

    I get this error when attempting to add the service reference using the https address:
    There was an error downloading 'https://223.1.1.21/AllSOAsrp/SOAServices.svc'.
    The request failed with HTTP status 404: Not Found.
    Metadata contains a reference that cannot be resolved: 'https://223.1.1.21/AllSOAsrp/SOAServices.svc'.
    There was no endpoint listening at https://223.1.1.21/AllSOAsrp/SOAServices.svc that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.
    The remote server returned an error: (404) Not Found.
    If the service is defined in the current solution, try building the solution and adding the service reference again.

    I have gone as far as deleting the service and application from the server and using last known version to work -- yet I still get this 'no endpoint listening at...' error.

    Could it be an IIS setting? Or some configuration that I am overlooking? Or...

    This is the application event viewer error message:
    WebHost failed to process a request.
    Sender Information: System.ServiceModel.Activation.HostedHttpRequestAsyncResult/38596285
    Exception: System.Web.HttpException (0x80004005): The service '/AllSOAsrp/SOAServices.svc' does not exist. ---> System.ServiceModel.EndpointNotFoundException: The service '/AllSOAsrp/SOAServices.svc' does not exist.
    at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)
    at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)
    at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.HandleRequest()
    at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.BeginRequest()
    at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result)
    at System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result)
    Process Name: w3wp
    Process ID: 1220

    I have read other threads that had this error stringlet in it, but none of the solutions seemed to fit.
    Any help is appreciated.

    Wednesday, August 4, 2010 2:36 PM

All replies

  • I know it's been two years you had this problem.

    I'm having the same problem, none of the solutions are working. Did you ever find a solution for this. Any help is appreciated.


    .net stuff

    Friday, November 16, 2012 11:27 PM