none
EWS) Managed API Compatibility ? RRS feed

  • Question

  • Hi ,

    I have used the EWS managed API version 1.2 to develop a program which connects with Exchange 2010 and reading inbox etc etc.

    I have the below questions.

    1.Is this API that I'm using so far compatible with Exchange 2013 ?

    2.if I Download API 2,compile ,will everything remains business as usual ?

    3.If it is not compatible  Should I write everything from scratch or some parts will need re factoring ?

    Thank you


    Monday, November 26, 2012 12:17 PM

Answers

  • 1. Yes

    2. 2.0 requires the .net 4.0 framework the the default version it will try to use when connecting is Exchange_2013 so as long as you have specified a version when you created the ExchangeService object you should be okay eg

    ExchangeService Service = new ExchangeService(ExchangeVersion.Exchange2010_SP1);

    The new Exchange 2013 specific features within the 2.0 Managed API won't work in 2010.

    Cheers
    Glen

    • Marked as answer by zakkar Wednesday, November 28, 2012 5:30 AM
    Tuesday, November 27, 2012 5:44 AM

All replies

  • 1. Yes

    2. 2.0 requires the .net 4.0 framework the the default version it will try to use when connecting is Exchange_2013 so as long as you have specified a version when you created the ExchangeService object you should be okay eg

    ExchangeService Service = new ExchangeService(ExchangeVersion.Exchange2010_SP1);

    The new Exchange 2013 specific features within the 2.0 Managed API won't work in 2010.

    Cheers
    Glen

    • Marked as answer by zakkar Wednesday, November 28, 2012 5:30 AM
    Tuesday, November 27, 2012 5:44 AM
  • Yes Glen , I have predicted in my code that before the connection the user have to select the version.

    So far I support until ExchangeVersion.Exchange2010_SP2. I believe that I will have to add something like ExchangeVersion.Exchange2013  (similar or something).

    .Net Framework 4 already installed so I'm OK then.

    Of course I will download the API 2.0 and compile with it because I want to remain up to date.

    Thank you very much Glen for your help.

    Wednesday, November 28, 2012 5:30 AM