none
Localization - Non Administrator Cannot Translate RRS feed

  • Question

  • Gentlemen, I have an application that translates strings based on Resource Dlls. My application translates fine. However, some of the resources are not translated unless I execute the application as an administrator. The funny part is that once I run it as administrator, the strings are always translated from that point on, even if I don't run the app as administrator anymore.

     

    Notes:

    - It could be a translation problem, like the strings are not correctly translated or something like that. However, that wouldn't explain why it works when I run the app as admin.

    - I debugged the application and didn't run into any exception related to translation.

    - I noticed that my AssemblyResolve event finds the resource dlls in both situations, therefore it does not seem like a configuration issue.

     

    Can anyone help me?

    Thanks a lot.

     

    Regards,

    Rafael Neves


    Regards, Rafael Neves
    Friday, July 15, 2011 6:29 PM

All replies

  • People, more information: my application is a client exe connecting to a Windows Service app. The exe resources are correctly translated, while the Windows Service ones are not, even though all the translation DLLs are in the same folder. It seems to be something related to the Windows Service user permissions...


    Regards, Rafael Neves
    Wednesday, July 20, 2011 8:28 PM