Visual Studio/Xamarin forum? RRS feed

  • Question

  • User2665 posted

    Is there any way we can get a Visual Studio forum? For feedback, questions and bug reports based around Xamarin development using Visual Studio. I think it would make sense.

    Thanks, Richard

    Friday, April 19, 2013 10:42 PM

All replies

  • User9249 posted

    Yea, that would be great.

    I have a few questions, I'll just ask them here. I'm using Windows 7 VM inside MacOS. I've been primarily a .NET C# programmer and have recently crossed over into doing iOS and Droid development using Xamarin, but I would prefer to use Visual Studio to do it in:

    1) The debugger seems.... bugged. If I encounter a run-time error, it often kills the app without any input from me and then VS is "hung" in run mode and doesn't respond to any input to stop the debugger. I have to kill VS. It also seems to lock the debug .pdb file every once in awhile and I'm unable to build the app. Restarting VS doesn't fix it, I have to reboot the entire VM for it to release it's hold on that file.

    2) There seems to be some sort of IO permission thing goin on. I have an iOS app that has some code that accesses a sub-folder in the app root directory. It's a simple folder with two .xml files inside. The app tries to access these files. It works just fine when deploy to simulator/device from Xamarin Studio installed on my MAC, but if I open up my Windows VM and run VS inside that same Mac, it tells me it was unable to find the specified directory, and sure enough when I use iExplorer to peek at the iPad's file system, it has created my app directory, but all sub-folders are just missing. The files reside inside the solution under a solution folder and are marked to copy out. It works from Xamarin Studio (Mac), but not VS2012 (Windows 7 VM).

    Any advice on these subjects would be great. I feel like if I could resolve these two issues I could use VS as my primary IDE... as of now, I am pretty much forced to use XS.

    Friday, April 26, 2013 5:23 PM
  • User9249 posted

    I've resolved #2 above, it was a VS quirk. I'm still having the debugging quirkiness, though.

    Monday, April 29, 2013 12:51 PM
  • User574 posted

    @BryanWeidman, with regards to the VS hang issues , do you have any further information that might help us track down the issue? Is it only on iOS or Android projects or both? On Emulators or devices? What VS Plugins/Addins do you have installed? We have been trying to replicate this issue and so far have been unable to do so. So any information you might have ,no matter have small or insignificant it might seem would really help us track down this issue.

    Thanks in advance.

    Tuesday, April 30, 2013 8:33 AM
  • User9249 posted

    I'm using VS2012 on a Windows 7 VM. It's a fresh install, so the only plug-in of note would be ReSharper... which I suspended in testing to see if it could be a problem (didn't fix it). I've only tried this on iOS projects, but I've tried both simulators and devices.

    The specific scenario I was getting this behavior was thus:

    I had a solution folder in a referenced project that contained some content files (xml), which were supposed to be copied out on deploy. Xamarin studio copied these out, but visual Studio apparently refused to do so (this is the quirky behavior I talked about in the post above; I resolved this for the moment by just moving the offending content file folder to the startup project). The code which tried to read said XML files into memory couldn't find the files, obviously, since VS wasn't copying the files out, and so it was throwing an IO error at run-time (this was during app boot-up), file not found. Easy enough. But that's when the app would just poof, die... and then VS would be stuck in debug mode and clicking the Stop button did nothing. I'd leave it for 5-10 minutes and no change, so eventually I had to just kill the process and start over.

    Tuesday, April 30, 2013 1:35 PM