none
Visual Studio 2005 is crashing in msxml6.dll when opening a platform builder project RRS feed

  • Question

  • Hi all,

    Just a couple of weeks ago I have started developing on Windows Embedded CE 6.0, which is competely new to me. So I was really greedy to dive into it. Installing all the necessary stuff (Visual Studio 2005, Platform builder, etc. ) worked fine so far and thanks to my team colleague, who has already some experience on that, I was about to gain ground regarding OS design and driver development.

    But my enthusiasm was suddenly stopped when Visual Studio 2005 started crashing when opening the plarfom builder project (*.pbxml).

    From the debugger I can see that it crashes in the msxml6.dll with an unhandled exception (0xC0000005: access violation reading location 0x00000000) and for more than one week now I am trying to find the reason but with NO success.

    I have tryed several things:

    • uninstalled platform builder and Visual Studio 2005
    • re-installed everything again
    • searched for updates for the concerned msxml6.dll
    • tryed to update the concerned msxml6.dll manually with the one from my colleague's PC
    • run Windows Update to update my Windows Vista system
      every available security and other patch is now on my PC
    • copied the project directory from my colleague
    • copied the platform builder directory (C:\Wince600) from my colleague
    • searched the internet back and forth
    • searched advise from my team colleague
    • run VS from the Visual Studio command prompt to get log data
      but it did not give any hint for the crash

    I then noticed that it is still possible to open the original platform builder project that we got from our CPU modul provider and which contains a basic OS design. Also it is possible to create new projects and to close and re-open them without any problem.

    Now I'm really at the end and I hope to get any help from the community.

    Is there a way to track down more in details the file(s) which are creating the problem?

    Any help and suggestion would be great!

    Regards,

    Schulz1

    Monday, November 14, 2011 2:22 PM

All replies

  • Problem solved!!

    Finally after a long way and after consulting one's pillow several times!

    A simple action - deleting the *.suo file - solved the problem.

    Who knows why I didn't think of it earlier since it is not the first time in my career that *.ncb, *.suo, *.sln and *.aps files turned out to be THE problem. Something really to keep in mind!!

    Thank you anyway

    Schulz1

    Tuesday, November 15, 2011 6:41 AM