The project type is not supported by this installation? RRS feed

  • Question


    VS2005 Team Suite RTM with SP1 Beta - XP SP2 - latest patches


    I have been learning XAML at the intro level. I had an old version of dotnetfx3 and wpf templates and I could create a project and run it.

    Yesterday I removed the old templates and the old framework with a removal tool and installed the RTM framework and new templates.

    However now I cannot open create a new project.

    The error message I am receiving is:

    "The project file c:\documents and settings\renee\localsettings\temp\4t4baj4.dyv\temp\WindowsApplication1 cannot be opened." The project type is not supported by this installation.

    I have not installed the extensions. I never have. I don't have enough disk space on the current system.

    What's missing?












    Thursday, November 16, 2006 7:33 PM



    This is fixed thusly:

    Setup Issues:

    1. A few users have seen a situation where when they try to create a .NET Framework 3.0 project, they get a package load failure for the WPFFlavor.  This appears to be due to having a machine that had earlier versions of Visual Studio, .NET Framework 3.0, and Visual Studio 2005 extensions for .NET Framework 3.0 (WCF & WPF), November 2006 CTP.  If you hit this problem, run "devenv /setup" from the command line and this package load failure should be resolved.
    Thursday, November 16, 2006 7:44 PM

All replies


    This is fixed thusly:

    Setup Issues:

    1. A few users have seen a situation where when they try to create a .NET Framework 3.0 project, they get a package load failure for the WPFFlavor.  This appears to be due to having a machine that had earlier versions of Visual Studio, .NET Framework 3.0, and Visual Studio 2005 extensions for .NET Framework 3.0 (WCF & WPF), November 2006 CTP.  If you hit this problem, run "devenv /setup" from the command line and this package load failure should be resolved.
    Thursday, November 16, 2006 7:44 PM
  • Hi,

    I'm facing the same problem,

    i've just installed vs 2005 team suite, while trying to open an asp.net web app. i'm getting the same message,

    "the project <file.csproj> file cannot be opened. the project type is not supported by this installation"

    tried to write  "devenv /setup" but it didn't help , i don't know if there is something wrong with the project file,

    some feature i didn't installed, or maybe somekind of .dll which is not currently on my machine (but this donesnt explain why can't I open the proj.)


    Thanks alot ,



    Sunday, November 19, 2006 1:08 PM
  • This may be a long shot, but did you install/uninstall XNA Game Studio Express Beta 1? If so, its uninstall contains a bug that will result in breaking several project types in VS 2005. So if you recently installed XNA Game Studio Express (beta 1, not beta 2) and then uninstalled it, then you should apply this workaround:

    1. Open a VS 2005 Command Prompt.

    2. Enter the following command:

            regsvr32.exe "%vs80comntools%\..\IDE\projectaggregator.dll"



    Monday, November 20, 2006 11:53 PM
  • Thanks! Running "devenv /setup" did the trick for me
    Friday, December 8, 2006 8:34 AM
  • I tried both suggestions in this thread (devenv /setup and regsvr32.exe "%vs80comntools%\..\IDE\projectaggregator.dll").  Neither has stopped this problem from happening.  I am running VS .net 2005 with .net 3.0 installed, and I can make .net 3.0 projects new, but can't open the ones I download from msdn.com as samples.  Also this is on a windows XP Laptop.
    Tuesday, January 16, 2007 9:15 PM
  • Hi.  I have exactly the same situation as you ... I can create new projects but cannot load existing projects.  Did you find a solution?
    Saturday, February 17, 2007 1:26 AM
  • Hello, i'm having the same problem, just installed Visual Studio 2005 Pro. and tried the devenv /setup command and re-tried loading one of the C# EXCEL examples.

    Please let me know if you were able to resolve this other than the devenv /setup command.

    Thanks very much





    Sunday, February 18, 2007 6:36 PM
  • I had the same problem. The problem was fixed after I installed the Workflow extensions also ( in addition to WCF & WPF Extensions for VS 2005)
    Monday, February 19, 2007 3:24 AM
  • The .NET 3.0 extensions worked for me, thanks!
    Monday, March 12, 2007 7:18 PM
  • Is the order of the add-in installations important? I mean do you have to install first Microsoft .NET Framework 3.0 and then Microsoft Visual Studio Extensions for Workflow Foundation or the other way around or it does not matter at all? I did the first on my home PC and everything works fine, while I did the second on my work PC and I still get this annoying message. The two PC configurations are almost the same (Windows XP and Visual Studio 2005 without SP1).
    Friday, April 20, 2007 9:00 PM
  • Genius!  This also happened after an uninstall of Orcas (VPC-only for me on Orcas from now on).  Thanks Steven!
    Monday, April 30, 2007 12:40 AM



    I just had to install these 2 and it did the trcik...





    (you might need to install the extra download in the down the atttached link's page)

    • Proposed as answer by nigwoko Monday, February 1, 2010 8:20 PM
    Monday, April 30, 2007 2:50 PM
  • I was having the same issue, and nothing was working on visual c# express orcas beta 1 release, I installed the


    OrcasVCSAprilCTPWPFPatch.exe when i try to install it it game me a warning saying that i need the cpt stuff in order to intall, i went ahead and install it anyway.. after that, i was able to create projects and the error message is gone.


    let me know if you need more help

    Thursday, May 10, 2007 7:39 AM
  • I had this recently with the new VS9.0 CTP when trying to create WPF projects...

    regsvr32.exe "%ProgramFiles%\Microsoft Visual Studio 9.0\Common7\IDE\ProjectAggregator.dll"

    solved it nicely.

    Monday, May 14, 2007 10:48 PM
  • Thanks C Herridge! - That solved it for me (C# Orcas Express).
    Friday, June 1, 2007 4:10 AM
  • Thanks hen1, it solved for me.
    That extra download you talk about
    Friday, June 1, 2007 11:29 AM
  • I am trying to open mobile application (PDA);
    i can't open already existing one nor create the new one because this error shows up;
    the funny thing is that one out of 20times i try it suddenly does let me do it, and once opened everything works perfectly fine... the problem is when i close it and try to open it again...
    I am trying to find the way to solve this problem for few days now;
    In each thread there is something different said to download and so i am downloading it, installing and still nothing (i guess i have lots of unneeded things on my comp now);
    i also tried the commands which were suppose to help but my system doesn't recognize any of them;
    I really don't know what to do anymore.. can anyone help me please?

    Wednesday, June 27, 2007 8:09 AM
  • Hi All,


    I have VS 2005 professional and installed the WF extension and still got the error " project type is not supported by this installation". I checked and saw under C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.0, there are quite a few dll belong to workflow such as System.Workflow.Activities.dll,  System.Workflow.ComponentModel.dll, etc. I also reran the package and the setup seems to think I have everything installed because everything is checked.


    Am I missing anything ?


    Wednesday, July 4, 2007 11:02 PM
  • Thanks. This worked for me.

    Run VS80-KB915364-X86-ENU.exe first, then

    run WebApplicationProjectSetup.msi.

    This will allow you to develop web applications in Visual Studio 2005.

    You don't need anything more than the standard install for .NET 2.0 on the destination sites to run web applications. This is entirely a Visual Studio add-in.

    Wednesday, July 11, 2007 8:33 PM

    I found I had to do all the steps mentioned, namely


    1) devenv /setup
    2) regsvr32.exe "%vs80comntools%\..\IDE\projectaggregator.dll"
    3) The download


    also called "Microsoft Visual Studio 2005 - Update to Support Web Application Projects"


    It was probably all important, however crucially I also had to run the command line


    4) devenv /resetskippkgs


    which is listed in the rather unfriendly error message that Visual Studio displays.

    Obviously at some point I had clicked the 'Yes' button and not the 'No' button when trying to get this to work.


    Thursday, July 12, 2007 10:39 PM
  • i've installed visual studio 2008 beta 2 .... the problem is when i'm going to create a new project smart device projects type is no appear in the window.. what should i do to solve this...........


    Tuesday, September 18, 2007 8:08 AM
  • I have the same problem with my VS 2005 Pro with WF extensions installed... did anyone find a fix for this? im tring to load a test project using smart client framework and the guidance packages..... the test project not supported by this installation. i have tried everything that has been suggested in this thread... no success.... 

    Friday, October 26, 2007 3:59 PM
  • For me, this did the trick :

    I installed "VS80-KB915364-X86-ENU" then "WebApplicationProjectSetup"

    Search Google to find them


    Saturday, October 27, 2007 7:11 PM
  • Anyone who is facing the above problem related to workflow project type, should download and install the Visual Studio 2005 extensions for .NET Framework 3.0 (Windows Workflow Foundation)http://www.microsoft.com/downloads/details.aspx?familyid=5D61409E-1FA3-48CF-8023-E8F38E709BA6&displaylang=en





    Tuesday, January 15, 2008 4:38 AM
  • Thanks a lot. It has worked in my case.



    Thursday, February 21, 2008 11:41 AM
  • after I install the workflow extension (Visual Studio 2005 Extensions for Windows Workflow Foundation (EN).exe), I was able to load in the asp.net web application into the visual studio 2005. One more suggestion is make sure that service pack 1 is also installed.

    Tuesday, March 11, 2008 12:09 AM
  • I had same problem but it was in VS 2008 professional Edition. devenv/setup did the trick for me.



    Wednesday, March 19, 2008 10:03 AM
  • I had the same problem when I installed Visual Studio 2008. Long story short, I fixed this by running devenv /setup from the command line.

    My error read: "...cannot be opened because its project type (.webproj) is not supported by this version of Visual Studio".

    I got this problem after I uninstalled Visual Studio 2003 and 2005 from my laptop and installed only 2008.

    Oh well. Hopefully this will help somebody with the SAME error description I had.

    Thursday, March 20, 2008 12:26 AM
  • Thanks Manolo, it helped me a lot!
    Monday, March 31, 2008 1:25 PM
  • guys, how do you do devenv/setup

    in the command line?


    I am using VS 2008. I am trying to open a solution built with VS 2008 in another machine,

    but I am getting error message of [The project type is not supported by this installation].

    I hope to hear from you.


    My OS: WIndows server 2003 R2, SP2 (Japanese version)





    Tuesday, April 1, 2008 6:05 AM
  • I encountered this problem working with WPF project types from VS2005 after uninstalling an expired Orcas beta.  I followed Robin Soole's process, but excluded step 3).  Most importantly, I needed to create a new WPF project before I could load an existing one.

    1) run devenv /setup from %ProgramFiles%\Microsoft Visual Studio 8\Common7\IDE
    2) run regsvr32.exe "%vs80comntools%\..\IDE\projectaggregator.dll"
    3) run devenv /resetskippkgs from %\ProgramFiles%\Microsoft Visual Studio 8\Common7\IDE
    4) Create a new WPF project, then close it.
    Friday, April 11, 2008 12:57 PM
  • I started facing the same problem all of a sudden in VS2008. Running "devenv /setup" fixed the problem. Thanks  


    Monday, April 21, 2008 9:10 AM
  • Same here, I was having problems creating/opening WF projects but just running "devenv /setup" fixed it.

    Monday, May 5, 2008 7:43 AM
  • Thanks a ton .....Stephen.

    Thursday, May 15, 2008 12:52 PM
  • I had the same problem when running an old .net 3.0 vs2005 project in vs2005 after I had installed vs2008 and .net 3.5. Since converting the project to vs2008 wasn't an option for me and since none of the fixes mentioned earlier in this thread solved my problem I had to find my own solution.

    I found that I no longer was able to create or open wpf content in vs2005 so I simply uninstalled .net 3.5 and reinstalled the 3.0 version and added the vs2005 extensions for .net framework 3.0 (wcf & wpf), november 2006 CTP (vsextwfx.msi).

    I havent tried to reinstall the 3.5 framework on top of what I have now but hopefully it wont screw things up for me.
    Tuesday, May 20, 2008 10:51 AM
  • I created this problem on my machine when I installed a piece of software that insisted on installing .NET Framework 1.1 (after 2.0 and 3.0 were in place.)

    So far, I haven't got a fix yet.
    Tuesday, July 8, 2008 6:38 PM
  • Hi,

    I've now had the same problem twice with VS2008 Pro on Vista64. Suddenly the WPF c# projects stop loading. First time the un-install/reinstall fixed it but not the second time and I again tried everything (or so I thought).

    Finally I noticed that the "devenv /setup" needed to be run as Admin (i.e. in vista with admin command line). If it is run without elevated priviledges, no error is returned, it just returns. When as with admin, it took about 30 seconds and fixed the problem.

    So, make sure you open the cmd.exe "Run as Adminitrator...", otherwise it wont work in Vista...

    Wednesday, September 3, 2008 5:50 AM
  • First install  Microsoft Visual Studio 2005 - Update to Support Web Application Projects (VS80-KB915364-X86-ENU.exe)

    and then try.

     It solved my problem.

    Thursday, September 4, 2008 9:14 AM
  •  I have the same problem. While trying to load an .asmx webservice I obtained the error:

    The project file ".... .csproj" cannot be opened.
    The project type is not support by this application.

    None of the suggestion that you entered worked. Any help please?
    Thursday, November 20, 2008 10:24 AM
  • Well, the problem was that I tried to open an ASMX document via Open file... Project/Solution. The solution is open the ASMX project using Open... Web Site and the project will be opened.
    Thursday, November 27, 2008 1:43 PM
  •   Hello everybody,

    I have Visual Basic 2008 Express Edition. Up until now, I have had no problems with it. Recently, I installed Microsoft Visual C++, Visual C#, and XNA Game Studio 3.0. After these downloads, it prompted me to register the product, which I had done a few months earlier. This is not my main problem, just a sign to me that something might have been wrong. Now, whenever I try to view the designer of a WPF application or user control, I get this error message:
    There is no editor available for _____.xaml 

    Make sure the application for the file type (.xaml) is installed.


    Wednesday, December 3, 2008 1:45 AM
  • I met the same problem.And it doesn't work after the suggestions(devenv /setup and regsvr32.exe "%vs80comntools%\..\IDE\projectaggregator.dll"). and it is still  not ok after i installed the file : VS80-KB915364-X86-ENU.exe. But it finally works after i install the SP1 for .net 2005. The file name is VS80sp1-KB926601-X86-ENU.exe. And it will take about 1 hour to install it. Hope this can help you.
    Friday, December 19, 2008 12:33 PM
  • HI

     I had this message "the project type is not supported by this installation" when I'm trying to load VS 2008 projects. These projects have been copied from other machines.
    I've done all suggested work around
    devev / setup
    Dll registration

    No result.

    Could some help

    Many thanks


    Tuesday, February 17, 2009 3:28 PM
  • I did not have the "web application" option for new projects, so I installed


    and that fixed my issue with loading the .csproj
    http://www.spudgames.com (flash games) http://www.tallyme.com (free dating and picture rating)
    • Proposed as answer by Waynes Strain Wednesday, May 13, 2009 4:06 AM
    Tuesday, February 17, 2009 4:59 PM
  • Hi All,

    Jade Skaggs> your suggestion helped me . Thank you very much
    Monday, April 27, 2009 12:09 PM
  • After running every update in this post and running the command line processes, which requires to be in admin priveliges. Nothing worked for me, but once I opened the project as a web page, it opened just fine and everything is swell from here on out.

    copied from _Ed Noepel

    1) run devenv /setup from %ProgramFiles%\Microsoft Visual Studio 8\Common7\IDE
    2) run regsvr32.exe "%vs80comntools%\..\IDE\projectaggregator.dll"
    3) run devenv /resetskippkgs from %\ProgramFiles%\Microsoft Visual Studio 8\Common7\IDE
    4) Create a new WPF project, then close it.

    Thanks by the way for supplying this info which might help other users
    • Edited by Waynes Strain Wednesday, May 13, 2009 4:09 AM
    • Proposed as answer by Sucy Thursday, May 14, 2009 2:25 PM
    Wednesday, May 13, 2009 4:07 AM

  • I have VS2005 and .net framework 2.0 installed...
    Still facing the same problem.

    Monday, May 25, 2009 6:14 AM
    Monday, May 25, 2009 10:22 AM
  • Hi All,

    I am using vs 2008 pro windows xp sp3,
    my problem is bit more complicate.
    1, my .net framework had some problems.

    the reinstall of  vs 2008, came up a problem:


    "Runtime Error
    An application has made an attempt to load the C runtime lib incorrectly.  Please contact the application's support team for more information.

    then I found a tool called "cleanup_tool.exe"


    .NET Framework Cleanup Tool User's Guide


    then I removed all my .net framework, then installed .net framework 3.5 sp1 full package( this one include 2.0 3.0 3.5 ).

    then reinstalled vs 2008. R6034 error has gone.

    2, "The project type is not supported by this installation" error pop up.

    then I found this page.
    I ran
    regsvr32.exe "%ProgramFiles%\Microsoft Visual Studio 9.0\Common7\IDE\ProjectAggregator.dll"

    then this error dispeared.

    3, but
    "There are no usable controls in this group. Drag an item onto this text to add it to the toolbox."
    there is nothing in workflow toolbox.

    then I found this page


    I ran

    cmd /c start /wait devenv /setup /resetuserdata /selfreg /resetskippkgs

    everything was fixed.

    thank you for your time.


    Friday, August 14, 2009 6:28 AM
  • Hi,

    This link solved my Problem.  Now I'm able to start WWF project,


    Just type in command prompt

    devenv / setup
    • Proposed as answer by SandeshMM Thursday, September 3, 2009 3:14 PM
    Thursday, September 3, 2009 3:12 PM
  • Hi guys,

    I'm trying to open SharePoint Reservations


    and get same message "The project type is not supported by this installation". I tried all solution that has been proposed at this thread - no result. Then a friand of mine said to delete one of GUID from <ProjectTypeGuids> line in csproj file. And it works!
    he alsou said that it's not a good way to open project files.

    Could anyone comment on this?
    Wednesday, October 7, 2009 8:35 AM
  • I simply hacked the csproj file, located the <ProjectTypeGuids> element and replaced it with one from another project - i.e one that loaded succesfully. So in other words, create a new c# project and open the csproj file, copy the <ProjectTypeGuids> element and paste it into the offending csproj file. This should work i hope.

    Friday, October 30, 2009 10:34 AM
  • this is due to MVC version, try to use the old version used to compile the project. In fact, I used MVC 2 but when I got the error, I changed it to MVC1 so it works fine for me!.
    Monday, January 18, 2010 4:24 PM
  • spam
    • Edited by sudarshans1 Sunday, January 31, 2010 4:15 AM spam
    Thursday, January 21, 2010 6:13 AM
  • Thanks C Herridge your solution works for me.

    Monday, January 25, 2010 9:11 AM
  • Thanks, this did the trick!
    Monday, February 1, 2010 8:20 PM
  • The real issue is that Visual Studio 2008 has a conflict understanding the "ProjectTypeGuids" defined in the .csproj file.  If you simply replace that tag with these other GUIDs, you can reload the project and it should open as expected. The templates for MVC aren't currently bundled with VS 2008, but instead are installed through a seperate "extension" download (which I don't have installed).  That seperate install probably contains the definition of the ProjectTypeGuid that Visual Studio was having a problem opening.


    <Project ToolsVersion="3.5" DefaultTargets="Build" xmlns=" http://schemas.microsoft.com/developer/msbuild/2003 ">



    <Project ToolsVersion="3.5" DefaultTargets="Build" xmlns=" http://schemas.microsoft.com/developer/msbuild/2003 ">


    In Summary, Remove the conflicting Guid !

    • Proposed as answer by PraveenK Wednesday, April 21, 2010 11:34 AM
    Monday, February 15, 2010 1:11 PM
  • I wanted to confirm that this fixed my issue, where a clean install of VS2008 + Silverlight SDK (tools, dev runtime, etc) opened up xaml files (from a previously created Silverlight app) in a plain text editor with no intellisense, coloring, etc.

    After first trying the "regsvr32 txtMgrP.dll" fix, then repairing VS2008 from the control panel/programs list, and then re-installing the SDK (all to no avail), running "devenv /setup" from the VS2008 command-line (I did it with elevated privileges, just in case) worked !  Finally, I can get back to work, thanks!
    Technology Applied
    Saturday, March 6, 2010 7:27 AM
  • Thanks Jade. This worked for me and fixed the issue.. Infact i was breaking my head for almost 2 hrs. Thanks again.
    Tuesday, April 6, 2010 12:09 PM
  • I have similar problem but in Windows 7 (64 bit machine with VS 2005)

    Find link below kindly suggest me solution. I tried whatever solutions were provided here but non of them work out.



    Thnx in Advance

    Tuesday, April 27, 2010 7:59 AM
  • Lately i missed the C# project  templates from vs2008 ,

    after run "devenv /setup" it works for me.


    thanks alot.

    • Proposed as answer by Amer jamaeen Monday, July 12, 2010 5:18 PM
    Monday, July 12, 2010 5:18 PM
  • Installing Service Pack 1 resolved my issue as well.



    Tuesday, July 13, 2010 9:33 PM
  • How did you run this devenv /setup, I tried but nothing happened. It took a while and then no messages. My Error is that, this project type is not supported by this installation of VS 2008. Can you help? I am trying to run SilverLight downloaded code for learning.

    Monday, August 2, 2010 7:44 PM
  • It seems that it can also be solved by opening the projectfile (project.csproj) in any editor like notepad and deleting everything between <ProjectTypeGuids></ProjectTypeGuids>.

    Worked perfectly well for me!!




    Wednesday, October 20, 2010 1:49 PM
  • Thanks,

    This trick worked for me!!!!


    Friday, January 14, 2011 10:09 AM
  • Thanks RT_123 !!
    Jay Hamlin
    Thursday, February 10, 2011 4:36 PM
  • Removing <ProjectTypeGuids></ProjectTypeGuids> worked charm...
    Friday, February 11, 2011 6:55 PM
  • Thanks Enrico Presti - fantabulous! Worked for me.
    Friday, August 5, 2011 3:38 PM
  • Thanks,

    This really worked for me

    Run VS80-KB915364-X86-ENU.exe first, then

    run WebApplicationProjectSetup.msi.

    This will allow you to develop web applications in Visual Studio 2005.

    You don't need anything more than the standard install for .NET 2.0 on the destination sites to run web applications. This is entirely a Visual Studio add-in

    • Proposed as answer by Noah Pressure Wednesday, September 28, 2011 2:33 PM
    • Unproposed as answer by Noah Pressure Wednesday, September 28, 2011 2:33 PM
    Tuesday, August 16, 2011 4:43 AM
  • I received this error on Visual Studio 2010, applied ASP.NET MVC 3 framework on top of the ASP.NET 4 runtimes, corrected this issue for me.




    Hope this helps someone! Gus

    Wednesday, September 28, 2011 3:14 PM
  • Hi,


    I am using Visual Studio 2005 Prof. Edition. Everything was working fine in my old machine. 

    When I chenged my machine it doesn't work. 

    I installed Service Pack 1 (VS80sp1-KB918525-X86-Beta-ENU.exe) it SOLVED my problem.


    Thanks for everyone.





    Thursday, October 6, 2011 5:03 AM
  • If you moved from one PC to another and you get this error while attempting to open a solution that used to work on your old PC, the very first thing you should do is compare the Visual Studio installation between your old & new PC's.

    For example, your solution may include a website, or a C++ project, but you neglected to install the required support for these project types when you installed VS on your new PC.

    • Proposed as answer by Matthys_DT Monday, December 10, 2012 12:42 PM
    Monday, December 10, 2012 12:42 PM