none
.NET 2.0 errors RRS feed

  • Question

  • Hello, I have been hearing alot of technical language about how to fix 2.0. I I am hesitant to go into bios and other deep system, or should I say, Awww, what did I do now? areas. But I was using Kodak Easyshare programs. It suddenly stopped working and every time I clean it out to reinstall, I get 2.0 is not working or corrupt.
     I am assuming that since that is tied in to my system, it may very well be the source of my computer being slowed down to  micro crawl and my sound not working.
     I have deleted 3.5 and reinstalled it because I read that is updates 2, but nothing and as many before me have tried. 2.0 will not go away or be repaired. The file doesn't exist.
     I did the MS Malicious scan and got nothing, I have McAffe and did a complete scan, nothing.
     I saw there was a Hot Fix for 1.0 awhile back. Since there are so many people with this problem, is there one for 2.0?
     Or a more "simpler" explanation on how to repair it?
     Any help would be appreciated.
       Thanks,
      Dennis
    • Moved by nobugzModerator Sunday, April 26, 2009 9:10 PM not a bcl q (From:.NET Base Class Library)
    Sunday, April 26, 2009 8:51 PM

All replies

  • There is an SP2 for .Net 2.0.

    Its packaged inside .Net 3.5 setup.


    Thanks, A.m.a.L | [Remember to click "mark as answered" when you get a correct reply to your question]
    Sunday, April 26, 2009 8:56 PM
  • It sounds like .NET 2.0 is corrupted. You can use this Cleaup tool to uninstall any versions you can't via the Add/Remove programs. Then you should try installing .NET 3.5 SP1 afterwads, since it also install .NET 2.0 SP2, v3.0 as well as v3.5. That can be downloaded from here:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=en
    Sunday, April 26, 2009 9:35 PM
  • I actually downladed the cleanup tool, but wasn't sure if the "Remove button" was to take it off the list or actually to be removed. The list has many programs that are working fine and I'd like to keep them.
     I did download SP 2, and will see if I can download the Kodak program.
     SO far, thanks.
    Sunday, April 26, 2009 9:40 PM
  • I just tried Kodak after downloading the actual SP2 and same thing. But thanks for the help.
    Sunday, April 26, 2009 10:27 PM
  • I uninstalled 2.0 and I tried to reinstall it, but to no avail. Should I remove ALL of the .NETs and reinstall 3.5? Or is this just asking for trouble?
    Monday, April 27, 2009 12:48 PM
  • Use the tool to uninstall every version of .NET, and then try installing .NET 3.5 SP1 again.
    Tuesday, April 28, 2009 6:06 AM
  • The removal tool removed everything but .NET 3.5 SP1 and it just won't go away. So I am going to try removing it in safe mode later too see what happens.
     SP 1 isn't even listed when I run the removal and it won't let me through the control panel.
     I did talk to the "Wizard" at work yesterday and he told me to get rid of them all also. He's good but hard to pin down when he is free.
    Wednesday, April 29, 2009 9:06 PM
  • You need to get rid of those 3.5 files. Make sure you have full access to those .NET folders.
    Friday, May 1, 2009 5:49 AM
  • I used the removal tool and 3.5 SP1 wasn't listed. I can't remove it that way or add/remove programs, even in safe mode. It just won't leave.
    Saturday, May 2, 2009 4:58 PM