locked
Why is search stuck at "starting"? RRS feed

  • Question

  • I have a VM running SP2010 SP1 and SQL Server 2008 R2. I had search running just fine, but I noticed that the Content Source is just stuck at "starting". I have tried stopping and starting, but still gets stuck. Search still works fine (since the search DB is populated with content). What's weird is that under Search Administration (at the bottom where it shows the DB's), Search_Service_Application_CrawlStoreDB is showing up as "Not Responding". Also, there isn't a Status for the Databases.

    I have looked in ULS and haven't found much. I have restarted SharePoint Search on windows and central admin. I have restarted Timer Service on windws and central admin as well.

    Any thoughts on how to troubleshoot?

    Friday, December 2, 2011 5:52 AM

Answers

  • Hey,

    You can check on this site under section "Configuring crawl"

    http://blog.concurrency.com/sharepoint/search-configuration-in-sharepoint-2010/

     

    Kr, Gokan


    Founder of SharePoint CookBook: http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    Thursday, December 8, 2011 8:58 AM

All replies

  • It has struck for me when i had entered a URL /content, which was not in the same farm in the content source. The content crawl account try to access it and get struck.
    SharePoint Specialist, Ashish Ranjan
    Friday, December 2, 2011 8:41 AM
  • Hi,

     

    This is the most commun problem under User Syncronization problem..

    Check this my resolution out on : Search Service volume 1 - Gokanozcifci.be

     

    It wrotes:

     

    robably, and the most of time, it will crash. You will see, you’re service will hang on User Profile Synchronization Service
                    This is the most common issue, to resolve this: 
                    Be sure that Service Pack1 and cumulative updates are installed.

    Mare sure that once you've updated hotfix for SharePoint 2010, you must use the command "psconfig -cmd upgrade -inplace b2b -wait" and then check product and patch installation status (Central Administration >Upgrade and Migration > Check product and patch installation status)
    For User Service Profile service account perspective, you must configure the following for this service account:

    • A member of Farm Administrator group
    • A member of Local Administrator group in the server you are running SharePoint 2010 as application server (Server Manager >Configuration > Local Users and Groups > Groups. R-click Administrators group and then select Add to Group. In the Administrator Properties windows, clickAdd and then select your User profile service account)
    • Log on locally policy in the server you are running SharePoint 2010 as application server (Start> Administrative Tools > Local Security Policy >Local Policies > User Right Assignment. R-clickAllow log on locally and select Properties. You will then do a few easily steps to complete configuration). Using the commandgpupdate /force to confirm the changes.

    You will then need to use the following command to stop User Profile Service Application due to "Starting" forever.
    Get-SPServiceInstance
    Stop-SPServiceInstance -Identity “service application GUID”
    Delete the existing User Profile service application and then re-provision one.
    After completely configuring properly permission for User Service Profile service account as well as re-provisioning a new User Profile service application, you start new User Profile service application and need to check FIM service. Make sure that two FIM services are started automatically. Don't force it to start because let User profile service automatically does.

     


    Founder of SharePoint CookBook: http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    Friday, December 2, 2011 10:04 AM
  • I am running on SP2010 SP1. I also have had User Profile Service running (and there is a user that has been synchronized).

     

    I have restarted Timer Service via 'net stop|start wptimerv4'. I also tried to stop/start SP Search through PowerShell, but I get a message through Central Admin on the Manage Services page: Error Stopping. Either way, the search service still seems to be running. I am a little boggled because the search crawler worked fine before... I can still execute searches, so I know permissions aren't totally messed up. I still see that Search_Service_Application_CrawlStoreDB is not responding... I am assuming this is the root of the problem.

    Any other thoughts?

    Sunday, December 4, 2011 10:42 PM
  • Have you tried to create a new Crawl store DB? I had the same issue with the Query Component / Index Partition, and creating a new parallel one fixed the issue. Once it was all running again I removed the old/original component.

     

    Monday, December 5, 2011 12:46 AM
  • Could you help me understand the steps (in more detail) to remove and re-create the crawl store DB? I appreciate it. Also, I have tried to delete the Content Source, but since it is stuck on Starting, I can't delete it.

    UPDATE: I went ahead and deleted the search service application, and then re-created it... All I had to do was go and enable the service application in the service application associations configuration (and then re-crawl).... All is well! Thanks for the help.

    • Edited by josh6847 Wednesday, December 7, 2011 8:53 PM
    Wednesday, December 7, 2011 8:02 PM
  • Hey,

    You can check on this site under section "Configuring crawl"

    http://blog.concurrency.com/sharepoint/search-configuration-in-sharepoint-2010/

     

    Kr, Gokan


    Founder of SharePoint CookBook: http://www.GokanOzcifci.be
    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    Thursday, December 8, 2011 8:58 AM