locked
People Picker control input textbox is not displaying in Internet Explorer RRS feed

  • Question

  • Please find the below code which i have for people picker

    <SharePoint:PeopleEditor runat="server" ID="processorid{generate-id()}" AutoPostBack="false" AllowEmpty="true" SelectionSet="User" BorderWidth="0px" PlaceButtonsUnderEntityEditor="true" Rows="1" AllowTypeIn="True" MaximumHeight="3" EnableBrowse="True" Width="200px"/>
    

    Im not able to view the input text box "border" in IE browser.

    Please find the below screenshot, the text box "border" is not displaying in all IE versions. However i am able to view in Firefox

    • Moved by Mike Walsh FIN Wednesday, August 24, 2011 11:48 AM customization q (From:SharePoint - Development and Programming (pre-SharePoint 2010))
    Wednesday, August 24, 2011 11:47 AM

Answers

  • Hi

    Copy paste the below style in your code and set the cssClass property of peopleditor to CssClass="ms-inputuserfield",it will help 

    <style type="text/css">

     

    .ms-inputuserfield

        {

            font-size: 8pt;

            font-family: Verdana,sans-serif;

        }

       

        div.ms-inputuserfield a

        {

            color: #000000;

            text-decoration: none;

            font-weight: normal;

            font-style: normal;

        }

       

        div.ms-inputuserfield

        {

            border: 1px solid #a5a5a5;

            position: relative;

            padding-left: 1px;

            padding-top: 2px;

        }

     

    </style>

    Then set the People Editor property

    <SharePoint:PeopleEditor runat="server" ID="processorid{generate-id()}" AutoPostBack="false" AllowEmpty="true" SelectionSet="User" BorderWidth="0px" PlaceButtonsUnderEntityEditor="true" Rows="1" AllowTypeIn="True" MaximumHeight="3" EnableBrowse="True" Width="200px" CssClass="ms-inputuserfield" />

     

     

    • Marked as answer by Arun Rajiah Wednesday, August 24, 2011 1:25 PM
    • Unmarked as answer by Arun Rajiah Wednesday, August 24, 2011 1:25 PM
    • Marked as answer by Arun Rajiah Wednesday, August 24, 2011 2:30 PM
    Wednesday, August 24, 2011 1:02 PM

All replies

  • Did you try to setting  BorderWidth="1"?
    --Cheers
    Wednesday, August 24, 2011 1:02 PM
  • Hi

    Copy paste the below style in your code and set the cssClass property of peopleditor to CssClass="ms-inputuserfield",it will help 

    <style type="text/css">

     

    .ms-inputuserfield

        {

            font-size: 8pt;

            font-family: Verdana,sans-serif;

        }

       

        div.ms-inputuserfield a

        {

            color: #000000;

            text-decoration: none;

            font-weight: normal;

            font-style: normal;

        }

       

        div.ms-inputuserfield

        {

            border: 1px solid #a5a5a5;

            position: relative;

            padding-left: 1px;

            padding-top: 2px;

        }

     

    </style>

    Then set the People Editor property

    <SharePoint:PeopleEditor runat="server" ID="processorid{generate-id()}" AutoPostBack="false" AllowEmpty="true" SelectionSet="User" BorderWidth="0px" PlaceButtonsUnderEntityEditor="true" Rows="1" AllowTypeIn="True" MaximumHeight="3" EnableBrowse="True" Width="200px" CssClass="ms-inputuserfield" />

     

     

    • Marked as answer by Arun Rajiah Wednesday, August 24, 2011 1:25 PM
    • Unmarked as answer by Arun Rajiah Wednesday, August 24, 2011 1:25 PM
    • Marked as answer by Arun Rajiah Wednesday, August 24, 2011 2:30 PM
    Wednesday, August 24, 2011 1:02 PM
  • I hope BorderWidth is for whole people picker, not for input textbox... :)
    Wednesday, August 24, 2011 1:25 PM
  • Thanks Naveen.. that works..
    Wednesday, August 24, 2011 2:30 PM