locked
Ask for related article - HTTP Error 500.24 - Internal Server Error RRS feed

  • Question

  • User1188170806 posted

    Hello,

    Below is an error happened when use IIS to open a web page.

    'An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.'

    I use IIS Console as usual, where should I do next to disable 'client impersonation'?

    I am looking the web page can open with authenticating login in three modes :

    (a.Active Directory /

    b.Local Machine logon /

    c.Any Stanger Logon)

    Best Wishes,

    Tós

    Monday, October 30, 2017 8:04 AM

All replies

  • User-2064283741 posted
    Have you tried running your app pool in classic rather than integrated pipeline mode?
    Monday, October 30, 2017 10:51 AM
  • User690216013 posted

    The "Classic ASP" subforum is for ASP only, not ASP.NET.

    For 500.24, you should refer to https://docs.microsoft.com/en-us/iis/application-frameworks/building-and-running-aspnet-applications/aspnet-20-breaking-changes-on-iis 

    Monday, October 30, 2017 1:10 PM
  • User-460007017 posted

    Hi Torviael,

    To disable the client impersonation, please go to IIS manager->server/site level->authentications->asp.net impersonation->disable. In addition, you could try to add validation attribute in system.webserver.

    <configuration>
       <system.webServer>
          <validation validateIntegratedModeConfiguration="true" />
       </system.webServer>
    </configuration>
    

    If the steps is not working, please compare the config file with the correct one.

    Best Regards,

    Yuk Ding

    Tuesday, October 31, 2017 2:22 AM
  • User1188170806 posted

    Finally I perform below action and the application pool have been solved.

    I. Backup the IIS entire Website data

    II. Adjust the web application pool to Classic ASP.net.

    III. Open the web page to broswer require web page successfully.

    Tós

    Monday, November 6, 2017 9:20 AM