none
Unhandled Exception "Could not find any available Domain Controller" RRS feed

  • Question

  • Hi,

    I keep on having exchange 2010 loosing contact to domain controllers.

    "Unhandled Exception "Could not find any available Domain Controller.". EventID 1. Once I restart the sever, this error disappear and reappear again after a few days.

    When I run AD setting, the result shows as below. Update version is currently as at 14.02.0342.003. And boths DCs have 100% uptime.

    PS C:\> Get-ADServerSettings | fl

    RunspaceId                                 : 9392eb25-bcdc-462e-816b-2d5626c572a5

    DefaultGlobalCatalog                       : DC2.com.au

    PreferredDomainControllerForDomain         : {}

    DefaultConfigurationDomainController       : dc1.com.au

    DefaultPreferredDomainControllers          : {DC2.com.au}

    UserPreferredGlobalCatalog                 :

    UserPreferredConfigurationDomainController :

    UserPreferredDomainControllers             : {}

    RecipientViewRoot                          :

    ViewEntireForest                           : True

    WriteOriginatingChangeTimestamp            : False

    WriteShadowProperties                      : False

    Identity                                   :

    IsValid                                    : True

    Could you please help as this exchange server has our management team and their outlook keep on going offline.

    Thanking you in advance.

    Cheers,

    Pwint

    Wednesday, November 6, 2013 3:55 AM

All replies

  • Hi

    When you get that error can you ping your DC? You can force Exchange to use a specific DC. Do you have any AV running on your DC or Exchange servers? Exclusions set correctly?

    Friday, November 29, 2013 7:23 AM
    Moderator
  • Hi Yes I can ping to both DCs. I found this link http://clintboessen.blogspot.in/2012/09/exchange-2010-randomly-loosing-access.html?m=1 on the web but not sure how reliable it is to follow instruction. I disabled AV just now and will update if this happens again as this losing domain controllers with event ID 2102 happens not everyday and normally a quick restart fixes the issue. Thanks, Pwint
    Sunday, January 5, 2014 2:18 PM
  • Hi Unfortunately By disabling AV doesn't help. Losing ldap connection is still happening and only the restart fixes the issue. Cheers, Pwint
    • Edited by Pwint Friday, January 10, 2014 10:52 AM
    Friday, January 10, 2014 10:52 AM
  • I have another issue. I was trouble shooting exchange bin folder for permission and as a result of it Exchange transport service stopped and couldn't restart. I quickly changed to local service account and able to restart. Fixed the transport roles folder permission but don't know the password of network service account so I can't change it back. I can send and receive emails internally and externally but I am worried that by running with local account maybe not recommended? Is it safe to reset network service password? Thanks. I am freaking out... Regards, Pwint
    Sunday, January 19, 2014 3:14 PM
  • Since I run KB939820 on all Windows 2003 DC in my environment, I havent had the issue for nearly a month.

    Cheers,

    Pwint

    Friday, February 28, 2014 5:39 AM