none
Error' message: 'Argument for '--module' option must be: 'none RRS feed

  • Question

  • Hi,

    I am working in SharePoint online Extension using SPFX.

    Here is the tsconfig.js file :

    {
    "extends": "./node_modules/@microsoft/rush-stack-compiler-3.3/includes/tsconfig-web.json",
    "compilerOptions": {
    "target": "es5",
    "forceConsistentCasingInFileNames": true,
    "module": "esnext",
    "moduleResolution": "node",
    "jsx": "react",
    "declaration": true,
    "sourceMap": true,
    "experimentalDecorators": true,
    "skipLibCheck": true,
    "outDir": "lib",
    "inlineSources": false,
    "strictNullChecks": false,
    "noUnusedLocals": false,
    "typeRoots": [
    "./node_modules/@types",
    "./node_modules/@microsoft"
    ],
    "types": [
    "es6-promise",
    "webpack-env"
    ],
    "lib": [
    "es5",
    "dom",
    "es2015.collection"
    ]
    },
    "include": [
    "src/**/*.ts"
    ],
    "exclude": [
    "node_modules",
    "lib"
    ]
    }


    I am getting the below error in Visual Studio Code.

    Kindly advice to resolve.Thanks in advance.

    file: 'file:///e%3A/THIRU/SPFX/PortalStyleExtension/tsconfig.json'
    severity: 'Error'
    message: 'Argument for '--module' option must be: 'none', 'commonjs', 'amd', 'system', 'umd', 'es6', 'es2015'.'
    at: '1,1'
    source: 'ts'

    Monday, October 12, 2020 6:28 AM