none
Can I uninstall .NET 2 SP2 if I have 3.5 SP 1? RRS feed

  • Question

  • This page https://support.microsoft.com/en-us/lifecycle/search/?sort=PN&alpha=.NET%20Framework suggests to migrate .NET 2 SP 2 with 3.5 SP 1. Does that mean I can uninstall 2 once 3.5 is installed? Will apps made with 2 still work?
    Tuesday, August 29, 2017 1:33 PM

Answers

  • Hi homer_3,

    Welcome to MSDN forum.

    No, you cannot use the .NET Framework 3.5 SP1 unless you also have the .NET Framework 2.0 SP2 and 3.0 SP2 installed. Therefore, you will not be allowed to uninstall the .NET Framework 2.0 SP2 or 3.0 SP2 if you have the .NET Framework 3.5 SP1 installed. If you try to uninstall the .NET Framework 2.0 or 3.0 when the .NET Framework 3.5 is installed, their uninstall processes will block and tell you that they are needed by another application on your system.

    You can also have a look at here: https://msdn.microsoft.com/en-us/library/bb822049(v=vs.90).aspx

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Wednesday, August 30, 2017 2:59 AM