locked
FastCGI Error 5 (0x80070005) RRS feed

  • Question

  • User292517993 posted
    Day of Goodwill, or evening
    Towns for my bad English

    with the installation of PHP on IIS through FastCGI gives the following message

    to test all servers running, but refused in the workplace
    Who can faced with a similar?

    FastCGI Error

    The FastCGI Handler was unable to process the request.

    Error Details:

    • Error Number: 5 (0x80070005).
    • Error Description: Access denied.

    HTTP Error 500 - Server Error.
    Internet Information Services (IIS)

     

    Monday, February 4, 2008 8:36 AM

Answers

All replies

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, February 4, 2008 2:59 PM
  • User-369092046 posted

    I was getting the same error (Windows XP SP2, IIS 6)

    Fixed it by going to IIS Mgmt

    Site Properties (on mine RC Default Web Site and select properties)

    Home Directory Tab

    Change "Application Protection" to "Low (IIS Process)"

    Click OK then do a iisreset from the command prompt...should work now.

    Wednesday, March 19, 2008 1:49 PM
  • User1865270445 posted

    I am having the same error.

    I am unable to locate the "Application Protection" that you are specifying above. Is this an XP only thing? I am running Server 2003.

    Is this a permission error? I am not sure where to start.

    Thursday, March 20, 2008 10:53 AM
  • User-369092046 posted

    Go into IIS Management and go the application pool properties this site is tied to.  Click on the Identity tab.  Note the user that this app pool is running under.

    Go to Local Users and Groups and add this user to the Distributed COM Users group.

     Start, Run, iisreset

    try again and let me know if that worked.  I don't have a 2k3 server here running php that I can use to test but this has solved many of my permissions problems in 2k3 IIS.

    Thursday, March 20, 2008 11:38 AM
  • User1865270445 posted

    That was a no-go.

     I am at a loss. I really want to get this working...just not have any luck with it.

    Friday, March 21, 2008 11:55 AM
  • User1865270445 posted

    NEVERMIND!!!

     I added permissions for Guest Account on php-cgi.exe and it works perfect!

     Not sure if it is a combo of what you suggested and that, but it works. Thanks!

    Friday, March 21, 2008 12:04 PM