locked
MobileOperatorNotificationHandler is not triggered while debugging

    Question

  • Hello,

    I have a problem with MobileBroadbandBackgroundTask registration and execution. The background task gets registered and executed if i manually install application(Creating appx package and deploying it through power shell), but when i run the application from Visual Studio, an instance of the BackgroundTask is created but its Run method is not invoked(Even i trigger the necessary events. Connecting/Disconnection profile, registering home etc). I enabled logging in EventViewer and checked the logs. You can find the two log item related to the issue. Do you have any idea what they mean? 
    Thanks

    First:
    An instance of a background task with entry point [EntryPoint] and name MobileOperatorNotificationHandler has been created in session 1 and given an ID of {e4b656c1-7151-4cfe-996d-7dd846d5678f}.

    Then:
    The description for Event ID 2 from source Microsoft-Windows-BrokerInfrastructure cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event: 

    EV_RenderedValue_0,00
    EV_RenderedValue_1,00
    EV_RenderedValue_2,00
    [GUID]_1.0.0.0_x86__nma8z8p0w8b1g
    53
    [EntryPoint]

    The message id for the desired message could not be found

    Saturday, July 28, 2012 9:15 AM

All replies

  • Have you tried running from Visual Studio on the Local, Remote and Simulator?  Do they all do this?

    Best Wishes - Eric

    Sunday, July 29, 2012 5:10 AM
    Moderator
  • Hello Eric,

    I tried on simulator but same thing happened. I am not able to debug on Remote for now. 

    Sunday, July 29, 2012 12:56 PM