locked
MDS 2014 - Could not load file or assembly Microsoft.SQLServer.Instapi error RRS feed

  • Question

  • Hello,

    I have just install MDS 2014 web application on different server then SQL server 2014 and MDS database. 

    When I connect to MDS as MDS/Administrator I get message “Could not load file or assembly ‘Microsoft.SQLServer.Instapi, Version= 12.0.0.0….”  
    When I try to connect as another user I get „Access is denied”  error.


    Please help  


    Tuesday, October 20, 2015 12:39 PM

Answers

  • Can you try SQL 2014 RTM CU10? It should have the fix as well.

    CU10 12.0.2556.4 KB3094220 October 19, 2015

    • Marked as answer by Zorko_ Friday, October 23, 2015 2:00 PM
    Wednesday, October 21, 2015 6:57 PM

All replies

  • When installing SMO 2014 (12.0.x) some DLLs are only installed to the GAC. To make your app work without having to manually install SMO in the target server, you must copy these DLLs with your app. Here are the paths where I got them from.

    C:\Program Files\Microsoft SQL Server\120\SDK\Assemblies\Microsoft.SqlServer.ConnectionInfo.dll

    C:\Program Files\Microsoft SQL Server\120\SDK\Assemblies\Microsoft.SqlServer.Management.Sdk.Sfc.dll

    C:\Program Files\Microsoft SQL Server\120\SDK\Assemblies\Microsoft.SqlServer.Smo.dll

    C:\Program Files\Microsoft SQL Server\120\SDK\Assemblies\Microsoft.SqlServer.SmoExtended.dll

    C:\Program Files\Microsoft SQL Server\120\SDK\Assemblies\Microsoft.SqlServer.SqlEnum.dll

    C:\Windows\assembly\GAC_64\Microsoft.SqlServer.BatchParser\12.0.0.0__89845dcd8080cc91\Microsoft.SqlServer.BatchParser.dll

    C:\Windows\assembly\GAC_MSIL\Microsoft.SqlServer.BatchParserClient\12.0.0.0__89845dcd8080cc91\Microsoft.SqlServer.BatchParserClient.dll

    C:\Windows\assembly\GAC_MSIL\Microsoft.SqlServer.SqlClrProvider\12.0.0.0__89845dcd8080cc91\Microsoft.SqlServer.SqlClrProvider.dll

    To access the GAC files you will need to disable the windows built-in viewer using the instructions provided by this article.

    An excerpt of the article for convenience:

    Open the registry editor and add/set the HKLM\Software\Microsoft\Fusion\DisableCacheViewer DWORD value: 1


    Please click "Mark As Answer" if my post helped.

    Tuesday, October 20, 2015 1:38 PM
    Answerer
  • May I know the exact version of your SQL Server 2014?

    We think it was a known issue has been fixed the in CU release.

    https://support.microsoft.com/en-us/kb/2936603

    I recommend you update the MDS to the latest SP1 CU3.

    Tuesday, October 20, 2015 7:16 PM
  • Tnx Vincent,

    MDS version is 12.0.2000.8

    I try to update to SP1 CU3, but problem is that I run MDS on separate server where only MDS is installed, and SP1 setup ask for SQL Server instance that Is not present.

    Is there the SP1 CU for MDS as standalone setup?


    Wednesday, October 21, 2015 1:12 PM
  • Can you try SQL 2014 RTM CU10? It should have the fix as well.

    CU10 12.0.2556.4 KB3094220 October 19, 2015

    • Marked as answer by Zorko_ Friday, October 23, 2015 2:00 PM
    Wednesday, October 21, 2015 6:57 PM