none
You cannot debug or run this project because the required version of microsoft office application is not installed RRS feed

  • Question

  • Hi,

    I have created an addin for Office 2010 and it was working good and i was able to debug using visual studio 2012.

    However, i also want the same addins for office 2013, so i uninstall 2010, and installed office 2013.

    When i am trying the debug the office addins, i am getting the error as 

    You cannot debug or run this project because the required version of microsoft office application is not installed

    Office Word binaries that i am referring is of v4.0.30319. Net framework is set to 4.0

    Embed Interop Types is set to false.

    Let me know if i am missing any step.

    regards

    Pushpendra


    Pushpendra

    Friday, May 16, 2014 12:14 PM

Answers

  • Hi,

    Based on the description, you got an error after update the Office application to 2013 from 2010.

    I assume you are developing an application add-in for Office. As far as I test, we need to update the assemble reference based on the version of Office application you installed like figure below:


    Then you also need to update the properties in the *.csproj file like figure below:


    After changed like steps above, the project works well for me.

    Whatever, I suggest you creating a new project target Office 2013 then copy the code from old project. It is easier and safer.

    Hope it is helpful.

    Best regards

    Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, May 19, 2014 7:05 AM
    Moderator

All replies

  • Hello Pushpendra,

    It looks like you need to replace Outlook 2010 PIA references with 2013 ones, i.e. retarget your add-in. You can read more about this in the How to: Target Office Applications Through Primary Interop Assemblies article in MSDN.

    Friday, May 16, 2014 12:50 PM
  • It is referring to C:\Program Files (x86)\Microsoft Visual Studio 11.0\Visual Studio Tools for Office\PIA\Office14\Office.dll

    And this is only PIA assembly i got.

    Is there another one i need to refer to

    regards

    Pushpendra


    Pushpendra

    Monday, May 19, 2014 6:49 AM
  • Hi,

    Based on the description, you got an error after update the Office application to 2013 from 2010.

    I assume you are developing an application add-in for Office. As far as I test, we need to update the assemble reference based on the version of Office application you installed like figure below:


    Then you also need to update the properties in the *.csproj file like figure below:


    After changed like steps above, the project works well for me.

    Whatever, I suggest you creating a new project target Office 2013 then copy the code from old project. It is easier and safer.

    Hope it is helpful.

    Best regards

    Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, May 19, 2014 7:05 AM
    Moderator
  • Grt thnx for quick reply and answer.. 

    cheers.


    Pushpendra

    Monday, May 19, 2014 7:44 AM