locked
Cisco Site to Site VPN RRS feed

  • Question

  • Hi there, we have a Cisco device on our side where I have setup a Site to Site VPN using the .cfg file downloaded from "Azure Networks" and I can get it connecting without a problem.  The problem is that we have XAuth enabled on our router for second level authentication when our users are connecting via their Cisco client.  As soon as I enable XAuth using this command (crypto map cm-cryptomap client authentication list userlist) my Azure VPN gets terminated.

    I was wondering if anyone had any way around this so my Cisco client users are still requested for second level authentication but the Azure Site to Site VPN is not.

    Thanks

    Phil.

    Wednesday, September 26, 2012 3:29 AM

Answers

  • I have actually been able to resolve this.

    My problem was that the crypto isakmp command needed to have "no-xauth" on the end.  So the full command should be as follows:

    crypto isakmp key [pre shared key] address [ip address] no-xauth

    Thanks

    Phil.

    • Marked as answer by Coffee-SERKO Wednesday, September 26, 2012 4:26 AM
    Wednesday, September 26, 2012 4:26 AM

All replies

  • I have actually been able to resolve this.

    My problem was that the crypto isakmp command needed to have "no-xauth" on the end.  So the full command should be as follows:

    crypto isakmp key [pre shared key] address [ip address] no-xauth

    Thanks

    Phil.

    • Marked as answer by Coffee-SERKO Wednesday, September 26, 2012 4:26 AM
    Wednesday, September 26, 2012 4:26 AM
  • I'm glad to hear that you resolve this issue. Thank you for sharing your solutions and experience here. It will be very beneficial for other community members who have similar questions.
    Thursday, September 27, 2012 6:10 AM