none
WiFi profile Proxy node for Windows Mobile 10 gives 418 error. RRS feed

  • Question

  • There is an issue when I try to deploy the WiFi profile to a Windows 10 Device.

    Once we add a particular SSID with Proxy node, and then try to delete and re-add the same SSID, I get the error  418 => node already exists.

    The point here is, I have deleted the node already which gives me a 404 not found. So the errors are contradicting. When I try to delete the Proxy node, it gives me a 404 error but when I add it, it gives me a 418 error stating the node exists.

    The same profile works fine in a Windows Phone 8.1 device.

    The profile I am using can be checked here: (I have added the snippet and omitted the SyncML tags)

    <Sequence>
    <Delete> 
      <Item>
        <Target>
          <LocURI>./Vendor/MSFT/WiFi/Profile/SSIDNew/WlanXml</LocURI>
        </Target>
      </Item>
      <Item>
        <Target>
          <LocURI>./Vendor/MSFT/WiFi/Profile/SSIDNew/Proxy</LocURI>
        </Target>
      </Item>
      <CmdID>InstallProfile;Collection=3001;Type=NonAtomicChild</CmdID>
    </Delete>
    
    <Atomic><Add> 
      <Item>
        <Target>
          <LocURI>./Vendor/MSFT/WiFi/Profile/SSIDNew/WlanXml</LocURI>
        </Target>
        <Data>&lt;WLANProfile
        xmlns=&quot;http://www.microsoft.com/networking/WLAN/profile/v1&quot;&gt;&lt;name&gt;SSIDNew&lt;/name&gt;&lt;SSIDConfig&gt;&lt;SSID&gt;&lt;name&gt;SSIDNew&lt;/name&gt;&lt;/SSID&gt;&lt;/SSIDConfig&gt;&lt;connectionType&gt;ESS&lt;/connectionType&gt;&lt;connectionMode&gt;auto&lt;/connectionMode&gt;&lt;MSM&gt;&lt;security&gt;&lt;authEncryption&gt;&lt;authentication&gt;WPA2PSK&lt;/authentication&gt;&lt;encryption&gt;AES&lt;/encryption&gt;&lt;useOneX&gt;false&lt;/useOneX&gt;&lt;/authEncryption&gt;&lt;sharedKey&gt;&lt;keyType&gt;passPhrase&lt;/keyType&gt;&lt;protected&gt;false&lt;/protected&gt;&lt;keyMaterial&gt;12345678&lt;/keyMaterial&gt;&lt;/sharedKey&gt;&lt;/security&gt;&lt;/MSM&gt;&lt;/WLANProfile&gt;</Data>
        <Meta>
          <Format>chr</Format>
        </Meta>
      </Item>
      <Item>
        <Target>
          <LocURI>./Vendor/MSFT/WiFi/Profile/SSIDNew/Proxy</LocURI>
        </Target>
        <Data>:</Data>
        <Meta>
          <Format>chr</Format>
        </Meta>
      </Item>
      <CmdID>com.mdm.19810717-dacb-4c3c-83b2-2434bdff8215.WinAllProfiles.wifipolicy;Type=Atomic</CmdID>
    </Add></Atomic>
    </Sequence>
    There is no syntactical error as the same exact profile works fine for Windows Phone 8.1 device.


    Tuesday, January 17, 2017 7:19 AM

Answers