locked
HTTP to HTTPS - Authentification Windows pops up RRS feed

  • Question

  • User1657197622 posted

    I have used CERTIFY to get a domain certificate from Let's Encrypt.

    I configured the URL rewrite - see web.config

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
    <system.webServer>
    <defaultDocument>
    <files>
    <clear />
    <add value="index.html" />
    <add value="index.htm" />
    <add value="index.php" />
    <add value="Default.htm" />
    <add value="Default.asp" />
    <add value="iisstart.htm" />
    <add value="default.aspx" />
    </files>
    </defaultDocument>
    <rewrite>
    <rules>
    <rule name="Redirect to Https" enabled="true" stopProcessing="true">
    <match url="(.*)" />
    <conditions>
    <add input="(HTTPS)" pattern="^OFF$" />
    </conditions>
    <action type="Redirect" url="https://{HTTPS_HOST}/{R:1}" redirectType="Temporary" />
    </rule>
    </rules>
    </rewrite>
    </system.webServer>
    </configuration>

    When I type https://www.akoscheminformatics.de I get a an authentification window. Even if I wanted I cannot log in with the server account. I host the server next to me.

    Second, related sssue: If I use the URL rewrite rule "redirect to HTTPS" on forum.akoscheminformatics and type https://forum.akoscheminformatics.de I get the errror "Server not found"

    Any idea where the problem might be?

    Alex

    Sunday, March 29, 2020 3:22 PM

All replies

  • User-460007017 posted

    Hi akosgmbh,

    Did you notice that the website return 401.2 from HTTP/API-2.0? The error message is not returned from IIS but http.sys. 

    When I access your http site, it just access the website with anonymous authentication. 

    And  I also notice there was a proxy support. So did you use proxy in front of your IIS server? If so please check your proxy setting. Besides,  please ensure SNI has been enabled and the certificate is 100% vaild. Otherwise, the certificate will be wrong.

    In addition, there was some syntax error in your rewrite rule.

    If you want to rewrite http to https, please modify your rule to

             <rule name="Redirect to Https" enabled="false" stopProcessing="true">
    <match url="(.*)" />
    <conditions>
                            <add input="{HTTPS}" pattern="^OFF$" />
    </conditions>
    <action type="Redirect" url="https://{HTTP_HOST}/{R:0}" redirectType="Temporary" />
    </rule>

    Best Regads,

    Jokies Ding

    Monday, March 30, 2020 4:04 AM