none
Unsuccessful Attempt to install .NET framework 2.0 & Automatic Updates Doesn't Activate RRS feed

  • Question

  • I cannot install .NET framework 2.0.  I keep getting the error message:

     

    Error 25015.Failed to install assembly ‘C:\WINDOW\Microsoft.NET\Framework\v2.0.50727\Microsoft.VisualBasic.Compatability.dll’ because of system error: 0x80131107

     

                                                                             Retry              Cancel

     

    Wednesday, August 31, 2011 3:47 PM

Answers

All replies

  • Mr. Stebner's repair file worked and solved my .NET framework 2.0 installation problem.  Now, I need to repair my Fix-It files and don't know how.

     

     

    Wednesday, August 31, 2011 4:45 PM
  • Also, my machine won't let me activate Automatic Updates
    Wednesday, August 31, 2011 4:46 PM
  • After I've successfully installed the FixIt 50362 software, I tried to run the Microsoft Fix It Center and I get the following message:

                     Microsoft Fix It Center has encountered an unexpected error, please try again. Error Code: 16977921-2147023836

     

     

     

     

     

     

     

     

     

     

                            When I try to open Microsoft Fix It Center, I encounter the following message:

     

    Microsoft Fix It Center has encountered an unexpected error, please try again. Error Code: 16977921-2147023836

     

    Wednesday, August 31, 2011 4:54 PM
  • have you already tried to install .NET Framework 3.5SP1?

    note that Fx3.5 SP1 has the same runtime of Fx 2.0, 3.0, 3.5 and when the installation starts, it reinstall all older version of his runtime before install Fx3.5 SP1.

     

    you can find the standalone installer here: http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

     

    After installing the .NET Framework 3.5 SP1 package you should immediately install the update KB959209 to address a set of known application compatibility issues.
    In addition, on Windows Vista x64 and Windows Server 2008 x64, install the update KB967190 to address a file association issue for XPS documents.


    || Michele Brina || Developer Support Engineer || http://blogs.msdn.com/itasupport
    Thursday, September 1, 2011 1:48 PM
  • Please tell us your Windows version and SP level.

    If you have Vista or Win 7, .NET Framework 2.0 is installed as an integral part of your OS and you cannot install it yourself.

    To check the integrity of installed frameworks, you shouls use this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Please report your results here.

    • Proposed as answer by Alexander Sun Monday, September 5, 2011 3:07 AM
    • Marked as answer by Alexander Sun Thursday, September 8, 2011 3:29 AM
    Friday, September 2, 2011 11:57 AM
  • Hi Jumpingjflash,

     

    Thank you for your post.

     

    You said you have installed .NET Framework 2.0 successfully. Do you have any issue about .NET Framework 2.0? If you have some problem about how to activate Automatic Updates or Fix Center, I recommend you go to Windows Answer forum to ask for helps.

    Windows Answer forum: http://answers.microsoft.com/en-us

     

    Thanks.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, September 5, 2011 3:09 AM