locked
Data Lake Store output - connection test failed RRS feed

  • Question

  • I'm trying to create the output sink as Data Lake Store - creation is successful but connection test fails. The error message is as follows:

    Access to 'testdls' was denied. Please make sure the user has at least read and write permissions to the specified Azure Data Lake Store. Exception: AccessTokenFromWrongTenant: The access token is from the wrong tenant 'f8cd...'. It must match the tenant 'fa2b...' associated with the Azure Data Lake account testdls.

    Do I do something wrong? Will Stream Analytics work properly despite unsuccessful test?





    • Edited by Devfingers Thursday, July 7, 2016 7:50 AM
    Wednesday, July 6, 2016 9:34 PM

Answers

  • Hi,

    We just deployed a fix to the New Azure Portal (https://portal.azure.com) which fixes this issue.

    Can you please create the Data Lake Store output again?

    Thanks!

    Ziv.

    • Marked as answer by Devfingers Friday, July 15, 2016 10:53 PM
    Friday, July 15, 2016 6:51 PM

All replies

  • Hi,

    Thank you for reporting this issue. Did you encounter the issue via the new portal?  If so, it is an issue that we are aware of and are working on fixing. In the meantime, as a workaround it should be possible to renew authorization via the classic Azure portal at https://manage.windowsazure.com/.

    Thanks,

    Kati


    This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, July 11, 2016 5:57 PM
  • Yes, I got this error message using the new portal.

    Following your advice I've deleted my output and I was trying to create a new one via the classic portal but I can't do that due to the following error during authorization:

    AADSTS70002: Error validating credentials. AADSTS70000: The provided access grant is invalid or malformed.\r\nTrace ID: da932af7-6756-4f69-8f6c-92f7636bb73e\r\nCorrelation ID: af164648-491e-4218-984b-df0613e9989b\r\nTimestamp: 2016-07-11 20:02:45Z

    After that I've created an output again (via the new portal), have gone to the classic portal and have renewed authorization but it doesn't help. Still test connection failed on both portals.
    • Edited by Devfingers Monday, July 11, 2016 8:21 PM
    Monday, July 11, 2016 8:09 PM
  • Hi,

    We just deployed a fix to the New Azure Portal (https://portal.azure.com) which fixes this issue.

    Can you please create the Data Lake Store output again?

    Thanks!

    Ziv.

    • Marked as answer by Devfingers Friday, July 15, 2016 10:53 PM
    Friday, July 15, 2016 6:51 PM
  • It works fine now :)
    Thanks!

    Friday, July 15, 2016 9:11 PM
  • Great!

    We have also fixed the Azure Classic Portal so the issue is now resolved in both Azure portals.

    Thanks!

    Ziv.

    Saturday, July 16, 2016 5:34 PM