none
new folder not showing up in GET call to REST api

    Question

  • Hi,

    I'm using jQuery with ajax to call the Gen2 rest api
    URL: https://myaccountxyz.dfs.core.windows.net/mycontainer1?recursive=false&resource=filesystem&directory=mydir1
    using a SAS token at the end of the URL.

    Using Internet Explorer, clicking a button to make the GET call returns a list of folders and files inside "mydir1".
    If I keep the browser open, and add a file or folder by some other means into "mydir1" (for example Azure Storage Explorer),
    and I make the GET call again, the new folder or file does not show up.
    Next, if I close the browser, restart it and make the same call, then it shows up.
    Can someone please advise why this could be happening?

    would really appreciate any help with this.


    Thanks
    Friday, March 29, 2019 8:43 PM

Answers

All replies

  • Hello Simplify3000 , 

    We tried to repro the issue and we are partly successful in that . If you upload a file ( we used Azure Storage Explorer) and fire a GET , it does pickup the new file details .

    But for folders that's not the case , we need to create the folder and also upload files , then only the folder is pushed on to the blob . I am not sure which version of Azure Storage Explorer you are using does call this out in the pop-up , I am attaching the same here .


    Thanks Himanshu

    Tuesday, April 2, 2019 12:22 AM
    Moderator
  • I added cache: false into the ajax call and that fixed it.

    • Marked as answer by simplify3000 Tuesday, April 9, 2019 2:49 PM
    Friday, April 5, 2019 7:42 PM