none
Error 0x80070643 during .Net Framework 4 installation in Windows 7 x64 RRS feed

  • Question

  • Hello. I'm trying to install the .Net Framework 4.0 on Windows 7 x64.

    I need to install an application (Microsoft LEAF M5) which requires .Net 4.0, but I cannot install it. The installation rolls back and the log file shows the error code is 

    0x80070643

    I Tried every single method I could find on the Internet. Deleted the Assembly folder and the contents of the TEMP folder, tried the microsoft Fixes, the cleanup tool, etc, nothing seems to work.

    This is not the first time I have this problem, last time was able to find a fix which consisted in changing a value in registry editor, but I cannot find the article again.

    This is what my log file has:

    OS Version = 6.1.7601, Platform 2, Service Pack 1
    OS Description = Windows 7 - x64 Home Premium Edition Service Pack 1
    CommandLine = D:\2194c6a61b22d17fdbb4\\Setup.exe /x86 /x64
    TimeZone = Hora de Verão de GMT
    Initial LCID = 2070
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Client Profile Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: AlwaysUploaded
    Number of applicable items: 9
    Exe (D:\2194c6a61b22d17fdbb4\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (D:\2194c6a61b22d17fdbb4\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null).
    Exe (D:\2194c6a61b22d17fdbb4\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    MSI (D:\2194c6a61b22d17fdbb4\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Client Profile Setup_20120413_212910577-MSI_netfx_Core_x64.msi.txt
    Exe (D:\2194c6a61b22d17fdbb4\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    MSI (D:\2194c6a61b22d17fdbb4\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Client Profile Setup_20120413_212910577-MSI_netfx_Core_x64.msi.txt
    Friday, April 13, 2012 10:12 PM

Answers

All replies

  • Have you done this series of steps exactly as described?

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Friday, April 13, 2012 10:54 PM
  • i'm sorry, but how can I run that first command (reset the ACL). Should I use cmd.exe and type the whole sentence? Is there an easier way?

    Thanks for the reply

    Friday, April 13, 2012 11:28 PM
  • You open a command prompt window As Administrator, paste it in at the prompt, then hit Enter.
    Saturday, April 14, 2012 4:51 AM
  • I tried it, I followed the spets religiously but It did not work.

    I have uploaded the vslogs.cab file to skydrive:

    https://skydrive.live.com/#cid=1A47DAF4F888F9F4&id=1A47DAF4F888F9F4%21614


    Saturday, April 14, 2012 1:59 PM
  • This error message indicates you have a Windows Installer problem:

    "INSTALLMESSAGE_ERROR [O serviço Windows Installer não pôde ser acedido. Isto pode acontecer se o Windows não está instalado correctamente. Contacte o suporte técnico para obter assistência.]"

    For assistance fixing your Windows Installer, search/ask here:

    http://answers.microsoft.com/en-us/windows/forum/windows_7

    Article like thi may help.

    http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_update/windows-7-installer-repair/48ce7096-5579-47d6-85b9-2fc0e0741aec

    Saturday, April 14, 2012 2:48 PM