locked
Blend 2 not launching VS 2008 when creating Event Handler RRS feed

  • Question

  • Hi,

    I have Blend 2 and VS 2008 Team Suite edition.  I installed VS 2008 first, followed by Blend.  When I go to create an event handler in Blend, it does not switch to VS (whether VS is open or not).  Rather, it says that it is pasting the event handler stub code to the clipboard and tells me that I need to install VS 2008.  And I have the "Event Handler" option set in Blend to use VS rather than the clipboard when available.

    Note also that when I have a solution open in Blend and I right-click on the solution node or a project node, the only option it gives me is to "Edit Externally."  It does not say "Edit in Visual Studio"  (which I recall was an option I saw in Blend 1).  However, if I choose "Edit Externally," it launches Visual Studio and opens the solution or project as expected.

    Is there a registry setting gone awry here?  Or something else?

    Thanks!
    Mike
    Wednesday, June 25, 2008 11:43 AM

Answers

  •  

    Hey Michael,

     

    You issue is due to fact the you installed SQL Server 2005 after installing VS 2008. SQL Server 2005 installs a cut down version of VS2005. So your current version of VS becomes VS 2005. This is evident from the registry key

     

    HKEY_CLASSES_ROOT\VisualStudio.DTE\CLSID.

     

    The value you have is {BA018599-1DB3-44f9-83B4-461454C84BF8} which points to VS 2005.

    The value for VS2008 would have been {1A5AC6AE-7B95-478C-B422-0E994FD727D6}

     

    You could correct this by changing the value of HKEY_CLASSES_ROOT\VisualStudio.DTE\CLSID to {1A5AC6AE-7B95-478C-B422-0E994FD727D6}.

    Thanks.


    Jeetendra Kukreja [MSFT]
    Friday, June 27, 2008 5:40 PM

All replies

  • Yes, it seems like a registry setting related issue - it looks like we cannot successfully interoperate with DTE in this case.

    Did you install VS 2005 in the interim? I can get someone to investigate.

    Thanks,
    Unni
    Thursday, June 26, 2008 12:23 AM
    Moderator
  • Using VS 2005 is not an option for me right now.  I can copy and paste the event handler code into VS 2008.  It is just that it takes a little more time.

    Why did the product ship this way?  Surely they tested the interoperability of Blend 2.0 with VS 2008?

    Please have someone investigate this as soon as you can.

    Thanks!
    Mike
    Thursday, June 26, 2008 5:50 PM
  • Michael, 

    We understand you concern here.

    Did you install SQL Server 2005  on you machine after installing VS 2008. I ask since there is a known issue around this and I wanted to confirm if you were running into it.
    It would be great if you could also tell me what the following registry settings on your machine look like?

    HKEY_CLASSES_ROOT\VisualStudio.DTE\CLSID

    HKEY_CLASSES_ROOT\CLSID\{1A5AC6AE-7B95-478C-B422-0E994FD727D6}\ProgID

    HKEY_CLASSES_ROOT\CLSID\{1A5AC6AE-7B95-478C-B422-0E994FD727D6}\LocalServer32

    Thanks.


    Just wanted to add you can contact me at jeetenk at microsoft.com directly.


    Jeetendra Kukreja [MSFT]
    Thursday, June 26, 2008 6:36 PM
  •  Hi Jeetendra,

    The registry settings are as follows (respectively):

    {BA018599-1DB3-44f9-83B4-461454C84BF8}
    VisualStudio.DTE.9.0
    "C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\devenv.exe"

    And yes, I did install SQL Server 2005 after installing VS 2008 and Expression Studio 2.0.  This was all done on a brand new machine.

    Thanks for all your help!

    Mike
    Friday, June 27, 2008 11:28 AM
  •  

    Hey Michael,

     

    You issue is due to fact the you installed SQL Server 2005 after installing VS 2008. SQL Server 2005 installs a cut down version of VS2005. So your current version of VS becomes VS 2005. This is evident from the registry key

     

    HKEY_CLASSES_ROOT\VisualStudio.DTE\CLSID.

     

    The value you have is {BA018599-1DB3-44f9-83B4-461454C84BF8} which points to VS 2005.

    The value for VS2008 would have been {1A5AC6AE-7B95-478C-B422-0E994FD727D6}

     

    You could correct this by changing the value of HKEY_CLASSES_ROOT\VisualStudio.DTE\CLSID to {1A5AC6AE-7B95-478C-B422-0E994FD727D6}.

    Thanks.


    Jeetendra Kukreja [MSFT]
    Friday, June 27, 2008 5:40 PM
  • That did it.  Thanks!
    Mike
    Friday, June 27, 2008 6:11 PM