none
.NET 2.0 issue solved by .NET 3.5 sp1? RRS feed

  • Question

  • We are having an issue when installing our software on localized (FR/ES/DE/DU) XP machines (Vista works fine).   We are using .NET 2.0 only, and I've tried installing .NET 2.0 SP2 to no avail.  The only update that seems to fix it is the .NET 3.5 SP1 (KB951847), but we don't want to force installation of .NET 3.5 on our user's systems.

    Is there a way to update .NET 2.0 past SP2 without including .NET 3.5 dependencies?

    PS - the specific issue is that our services won't start with the dreaded CLR20R3 failure in mscorlib.  R9 which usually shows the exception type, is full of garbage.
    Friday, July 24, 2009 9:22 PM

All replies

  • Hi,

    You can find a lot of hotfixes here: http://code.msdn.microsoft.com/Project/ProjectDirectory.aspx?TagName=Hotfix&ProjectSearchText=Hotfix

    However, without knowing the exact root cause, we're shooting in the dark, how would you know which hotfix to apply? Or could the error caused by a bug in your own code?

    If you could find out more detailed error information like exception type and call stack, it will be very helpful to the troubleshooting.

    The shortcut to the solution is to install .NET Framework 3.5 SP1 as you said it seems to fix the problem. Actually, the .NET Framework 2.0 SP1 download information page has the following note:

    IMPORTANT: After installing the .NET Framework 2.0 SP2 update you should immediately install the update KB959209 to address a set of known application compatibility issues.

    So if it is not a big problem, just apply 3.5 SP1 updates; otherwise, you may want to debug the application or added some unhandled exception log code to you application, so you can have more detailed information of what exactly the problem is.

    Regards,

    Jie
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Send us any feedback you have about the help from MSFT at fbmsdn@microsoft.com.

    The CodeFx Project
    My Blog (in Simplified Chinese)
    Monday, July 27, 2009 3:30 PM
    Moderator