locked
BizTalk Application Migration from 2103R2 to 2016 RRS feed

  • Question

  • Hello All Experts,



    We are working on a Biztalk migration project from Biztalk 2103 R2 to 2016. When I open the solution file in  Visual Studio 2015 I am getting below error message. The original project and solution was built using Visual Studio 2013. How to resolve the issue and what component is missing. Will I face the same issue every time I open the new interface in VS 2105. I cannot upload image or screenshot as I am getting error message as account not verified.

    Maps, Orchestration and Schemas are not opening and there is a red crossmark. whereas I have a green tickmark for deployment, helper and Solution (.sln)

    Can someone please guide in resolving the issue.

    Tuesday, June 25, 2019 6:47 AM

Answers

  • You need just Visual Studio 2015, BizTalk Server 2016 Developer edition including the SDK and SQL Server 2016.    
    • Marked as answer by RohitG21 Thursday, June 27, 2019 6:48 AM
    Wednesday, June 26, 2019 9:07 PM
  • Without the SDK installed, Visual Studio does not know about BizTalk projects.
    • Marked as answer by RohitG21 Monday, July 1, 2019 12:02 PM
    Thursday, June 27, 2019 9:02 PM

All replies

  • Do you install the developer SDK for BizTalk 2016 after you installed VS 2015?
    Tuesday, June 25, 2019 9:10 PM
  • HI Colin,

    Thanks for the  update. No, I have not installed the developer SDK for BizTalk 2016. I also have one doubt. Do I need to install Biztalk 2013 and VS 2103 as well or Visual Studio 2015, BizTalk 2016 and SQL Server 2016 is enough for migration.


    Thanks, Rohit Gaikwad BizTalk Developer

    Wednesday, June 26, 2019 6:15 AM
  • There's no error message in you original post.  Can you include the complete message text?
    Wednesday, June 26, 2019 10:45 AM
    Moderator

  • Thanks, Rohit Gaikwad BizTalk Developer

    Wednesday, June 26, 2019 11:15 AM
  • HI Colin,

    Below is the screenshot of the error mesage.


    Thanks, Rohit Gaikwad BizTalk Developer

    Wednesday, June 26, 2019 11:16 AM
  • There's no error message in those posts.  Can you include the complete message text?

    Wednesday, June 26, 2019 12:14 PM
    Moderator
  • You need just Visual Studio 2015, BizTalk Server 2016 Developer edition including the SDK and SQL Server 2016.    
    • Marked as answer by RohitG21 Thursday, June 27, 2019 6:48 AM
    Wednesday, June 26, 2019 9:07 PM
  • HI John,

    Sorry my bad I thought I uploaded the whole screenshot. PFA updated screenshot with complete message text.


    Thanks, Rohit Gaikwad BizTalk Developer

    Thursday, June 27, 2019 6:47 AM
  • HI Colin,

    Thanks for the update. PFA updated screenshot with complete error message text.


    Thanks, Rohit Gaikwad BizTalk Developer

    Thursday, June 27, 2019 6:48 AM
  • Without the SDK installed, Visual Studio does not know about BizTalk projects.
    • Marked as answer by RohitG21 Monday, July 1, 2019 12:02 PM
    Thursday, June 27, 2019 9:02 PM
  • OK thanks for the update.

    Thanks, Rohit Gaikwad BizTalk Developer

    Monday, July 1, 2019 12:02 PM
  • Hi Rohit, were you able to resolve this issue ?

    If so, please let us know what did you do to overcome this so it will be helpful for others when reading this forum with similar issue ? Thanks


    RH

    Monday, July 8, 2019 2:53 AM
  • HI Dan2890,

    Yes I was able to resolve the issue. I installed Visual Studio 2015, BizTalk 2016 and SQL Server 2016 only. And I was able to open the solutions in VS without any issues. 


    Thanks, Rohit Gaikwad BizTalk Developer

    Tuesday, July 23, 2019 12:51 PM