locked
Unable to add application to group with application credentials RRS feed

  • Question

  • Steps to reproduce:

    1) Create a new AD appliaction(say adminapp)

    2) Go to configure page-> Permissions to other applications and add "Windows Azure Active Directory"

    3) Get the app Id and key of this newly created app(adminapp)

    4) Create 1 more application(sampleapp) and 1 group(samplegroup)

    5) Using the application credentials of adminapp, use Grapclient to add samplegroup to sampleapp.

    6)This fails with an exception "Unable to add application to a group :Microsoft.Data.OData.ODataErrorException: Insufficient privileges to complete the operation. ---> System.Data.Services.Client.DataServiceRequestException: An error occurred while processing this request. ---> System.Data.Services.Client.DataServiceClientException: {"odata.error":{"code":"Authorization_RequestDenied","message":{"lang":"en","value":"Insufficient privileges to complete the operation."}}}"

    This worked earlier. But failing for the past 2 days.


    Monday, August 31, 2015 11:54 AM

Answers

  • Hello,

    Greetings!

    We are pleased to answer your query. With regards to your query, Could you please check whether you had given Read Directory Data permission as shown the below image. If yes then there would be a limited access via app comparatively with an Graph Explore etc.

    Hope this helps!
    Best Regards
    Kamalakar
    _____________________________________________________________________________________
    If a post answers your question, please click Mark As Answer on that post and Vote as Helpful.

    Monday, August 31, 2015 6:19 PM

All replies

  • Hello,

    Greetings!

    We are pleased to answer your query. With regards to your query, Could you please check whether you had given Read Directory Data permission as shown the below image. If yes then there would be a limited access via app comparatively with an Graph Explore etc.

    Hope this helps!
    Best Regards
    Kamalakar
    _____________________________________________________________________________________
    If a post answers your question, please click Mark As Answer on that post and Vote as Helpful.

    Monday, August 31, 2015 6:19 PM
  • Hello,
    We hope that the last response helped resolve the issue. We would like to now mark this thread as ‘Answered’, which can help others facing the same issue. If you’re still facing any issues, please write back to us, and we can continue working on this.

    Best Regards,
    Kamalakar
    Sunday, September 6, 2015 11:28 AM
  • Hi,

    This issue started appearing again from today. I am not able to create app/groups using Application credentials.

    Screenshot attached.

     

    Wednesday, October 7, 2015 7:24 AM